Support » Fixing WordPress » Internal Links Change URL but Don’t Redirect

  • I’m working on a client’s site that recently ran into a slew of issues that quickly spiraled out of control last week. We have most of them fixed except the first: all of the internal links on the site are not redirecting. The URL in the address bar changes, but the site just reloads the current page. I have reset the Permalinks settings and the .htaccess folder (as well as other things such as increasing the hosting memory which my client had set very low), but the issue still persists. I have also updated all plugins (there is only the Avada theme plugins and Contact Form 7 plugin).

    Anybody know where else I can look to fix this issue? I appreciate any help and direction.

    • This topic was modified 3 months, 1 week ago by Jan Dembowski. Reason: Moved to Fixing WordPress, this is not an Everything else WordPress topic

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • The URL in the address bar changes, but the site just reloads the current page.

    Is a Redirect Plugin of any kind being used or are manual changes being made to the .htaccess file? If the latter can you provide an example the Redirect logic being used?

    I am having the same issue. I have disabled all plugins, switched themes, reset the permalinks, rewrote the htaccess file, and reinstalled wordpress — still have the issue.

    Thread Starter jerrylawless3

    (@jerrylawless3)

    Yeah, it’s bizzare. I ended up just installing a media export plugin and rebuilding the entire site on Webflow, and we’re going to build all of our client sites there from now on. It took a couple days, but hopefully will prevent more issues like this down the road.

    @wendybedell Is your site hosted at GoDaddy?

    @jerrylawless3 Is Webflow a hoster or another type script?

    Yes it is hosted with GoDaddy. I even tried rolling WordPress back to version 5.7 and it still didn’t work. I can’t think of anything else to do? I feel like I’ve tried everything. Maybe I’ll move it to a different host?

    I notice Wendy, that there is no caching setup for your site. Add the following to your .htaccess (at very top) and see if problem persists.

    #################################################
    ##  Expires Caching for pages
    
    <filesMatch ".(x?html?|php)$">
      Header always set Cache-Control "max-age=300, private, stale-while-revalidate=3600, stale-if-error=259200"
    </filesMatch>
    
    #################################################

    The above tells Browsers to cache the page for 5 minutes. If you use Browser Dev Tools right now, you’ll see there is no ‘cache-control’ in the Response Header for your Home page. After inserting the above and reloading the page (CTRL + F5) you will see the above ‘cache-control’ setting.

    Let me know if it helps at all with your problem.

    wendybedell

    (@wendybedell)

    Thank you, Rob. I just received this from GoDaddy: It appears that there is some kind of website/hosting-side caching in place that keeps serving the same content.

    Now they want me to reach out to hosting.

    Website Rob

    (@website-rob)

    Although I’m still not sure exactly what problem you’re having, no example to go by, did the cache code I provided help at all?

    sherryl

    (@sherryl)

    I’m having the same problem and also use GoDaddy. I contacted them last week and they didn’t have a clue what was causing the problem. Please share any resolutions.

    sherryl

    (@sherryl)

    I just called GoDaddy again and had them look at a server cache issue and they do not see any problems on their end. They still state the problem is a WP one.

    Website Rob

    (@website-rob)

    Without seeing an example or any error log output to go by, you’ll have to depend on your Hosting Support for help. Ask them to look at the error logs or show them an example they can test.

    sherryl

    (@sherryl)

    I just followed ‘Website Rob’s’ suggestion and that fixed the problem!!!
    Thank you!

    Website Rob

    (@website-rob)

    I made two suggestions. Which one worked for you?

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.