Support » Fixing WordPress » Internal Links Are Suddenly Nofollow

  • Chocolate-Covered Katie

    (@chocolate-covered-katie)


    The latest wordpress update somehow seems to have added “nofollow noopener noreferrer” to both external AND internal links that were set to open in a new tab (target_blank) for all of my posts.

    Is there a way to change it back so that internal links opening in a new page are switched back to dofollow links?

    Thanks in advance for any help! (I searched the forums before posting this but could not find anyone with the same issue, so hopefully this is not a duplicate.)

    chocolatecoveredkatie.com

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    I’m not seeing that on any of my sites, so it may be an interaction with something else.

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    Chocolate-Covered Katie

    (@chocolate-covered-katie)

    Thanks so much for the reply. I tried disabling the plugins, but unfortunately the issue (which started right after the newest WordPress update) remained.

    However, I noticed when I used Chrome to inspect the code of a few other websites using the same theme (Genesis) that they seem to have the same “noopener noreferrer” in their internal links now too. I will do more research and will ask on the Genesis board. But if anyone happens to see this post and knows how to solve it, please feel free to reply!

    As I wrote here:

    I have the same issue.
    When I crated a new page today and set all links as nofollow the “noopener noreferrer” was added. There is no chance to delete it! It is always added again and again after having been removed…

    First time this occurred. I updated to 4.7.4 yesterday. I use theme Enfold.

    This is annoying. Please solve it – thank you!

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Please see

    https://wordpress.org/support/topic/remove-rel-noopener-noreferrer-in-wordpress-4-7-4/#post-9057251

    I’m closing this thread in the hopes of consolidating the discussion.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Internal Links Are Suddenly Nofollow’ is closed to new replies.