Support » Fixing WordPress » internal link doesn’t load index.php

  • justhavealook

    (@justhavealook)


    Hello,
    I have this trouble and already read lot of topics but I did not find any solution.
    Examples with a click I have this (working local) http://localhost/wo/?page_id=9
    http://localhost/wo/?p=7#respond
    http://localhost/wo/?m=200701
    nothing load the index.php
    except (strange) my internal links to gallery2 (I have wpg2 plugin).
    I tried with other themes, with plugin desactivated it’s the same.
    Everything is okay but not this !
    My configuration(
    Wordpress 2.1
    Plugins : utw and wpg2
    Apache2
    php 4.0.15
    Thanks in advance for your help and sorry for my bad english (I’m french).

Viewing 4 replies - 1 through 4 (of 4 total)
  • MattFroggett

    (@mattfroggett)

    What are you trying to do? I could try and help you, but I dont fully understand your point

    michaelisc

    (@michaelisc)

    I hope this helps. I was nearly driven nuts trying to figure out why index.php would not load when I logged in as administrator. I always had to manually append “index.php” to get the dashboard to load.

    Quite by accident I discovered that the problem was on the server side. I use Webhost4life as my host and I had somehow turned off the root in the “Set Dir browsing” option of the control panel. Once I turned the root back on then it worked fine. Check with your host and see if something like this might be the problem.

    justhavealook

    (@justhavealook)

    Thanks for your help,
    in fact that’s exactly the same trouble that michaelisc describes.
    I always had to manually append “index.php”for all internal links.
    It’s never loading index.
    But it’s on my computer, working local and I wish to host my site on my computer at the begining.
    I was thinking that may be it’s not a trouble with my configuration with apache2 because the links with my embedded gallery (plugin wpg2) working.
    Thanks again.
    PS : I’m working with Macintosh

    justhavealook

    (@justhavealook)

    Ps : links with utw like wpg2 working too.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘internal link doesn’t load index.php’ is closed to new replies.