Support » Installing WordPress » internal error or can’t find database

  • Gah !! My DB name is actually ‘killerr_a’ but if I enter that I get an Internal Error 500 message, and if I leave off the ‘killerr_’ prefix of course it can’t find the database although it can talk to the server. Why can’t it handle the ‘illerr’ prefix???

    define(‘DB_NAME’, ‘a’); // The name of the database
    define(‘DB_USER’, ‘killerr_wordpres’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘dominguez’); // …and password
    define(‘DB_HOST’, ‘’); // 99% chance you won’t need to change this value
    define(‘DB_CHARSET’, ‘utf8’);
    define(‘DB_COLLATE’, ”);

Viewing 8 replies - 1 through 8 (of 8 total)
  • The internal server error may be related to something else. If your db name is killerr_a, then you should be using that. Are you sure your db host isn’t localhost? Try it with localhost, too. That is what it should be most of the time.

    Yes I tried ‘localhost’ but then it can’t connect to the server. With ‘’ it can talk to the server, but then either shows an internal error if I use the ‘killerr_a’ database name (which is the correct name)or says it can’t find the database because the name is wrong. Basically using the killerr_a name causes an error – I have tried different database names, but they all have to have the ‘killerr_’ prefix, which seems to cause the error for some reason???


    have you been able to get this to work without the “killerr” name involved. Isn’t the whole point of this is to get your database to be accessible by wordpress. Before making assumptions you should try getting it to work with different types of database names, its most likely that the name has nothing to do with the errors. If it is the case that you the character string “killer” the problem, you should just consider another name for the database.

    If you look up what exactly an 500 Internal error means:

    Resolving 500 errors – general

    This error can only be resolved by fixes to the Web server software. It is not a client-side problem. It is up to the operators of your Web server site to locate and analyse the logs which should give further information about the error.

    Also check with your host to see if your db is actually online and operational. Double check usernames the works etc.

    if your host has vDeck – review this

    I use H-Sphere to set up my database names and it requires that you have the user name prefix, in this case killerr .I have tried several different names but they all have to have that prefix. If I put the name in I get a 500 error, if I don’t it connects to the server but can’t find the database.
    I tried the test connection php script and that works fine so I know my server is OK. I can connect to that database fine using phpMyadmin. Username and password are definitely OK. Host does not use vDeck.

    for db host on h-sphere is usually similar to
    (not localhost or ip)

    The thing is, it


    connecting to the server OK. The name of the database is now killerr_blog.

    If I edit it in the config file so it’s called killer_blo I get the “We were able to connect to the database server (which means your username and password is okay) but not able to select the killerr_blo database.” message. But as soon as I change it to the correct name, killerr_blog, I get the Internal Server error message straight away.

    Well, I gave up and tried Textpattern instead and the whole install worked perfectly and took about 3 minutes, using exactly the same database and user names…

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘internal error or can’t find database’ is closed to new replies.