Support » Plugin: WooCommerce - ActiveCampaign » Internal Error

  • wandriska

    (@wandriska)


    When I enable this plugin, every sale made on site falls over at the checkout. I get a “internal server” error.

    It used to work fine, however now it does not.

    No error messages generated in the logs
    The only thing I can think of is either an update caused a problem
    OR
    I changed the URL on site, on backend to https…..I had forgotten to do that when I moved the site to https 2 years ago. I have gone through and checked URLS on WOO and AC…can’t see any issues.

    Any ideas for a fix.

    thank you
    Andrew

    • This topic was modified 6 months ago by wandriska.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • wandriska

    (@wandriska)

    I

    • This reply was modified 6 months ago by wandriska.
    Plugin Author equalserving

    (@equalserving)

    Hi,

    You said that you enabled logging and nothing was added to the log file.

    Can you please add a product to your cart and go through the purchase process as far as it will take you.

    Once the sale fails, go to the link below and follow the directions at Step 3 to send us the contents of the log file for today. Open a support ticket and attach the log file.

    https://equalserving.uservoice.com/knowledgebase/articles/1889128-customers-are-not-being-added-to-activecampaign

    Thanks

    wandriska

    (@wandriska)

    I will do as you suggest. However what I have isolated that the issue disappears when I disable the /WC-AC Hook/ plugin.
    There is definately a conflict there.
    I will do some testing over the weekend.
    thank you

    wandriska

    (@wandriska)

    mm.. I was looking at the WP logs..not WC so

    I had a quick look at the WC ones and this is what I found:

    2019-09-24T10:38:22+00:00 CRITICAL Cannot declare class AC_Connector, because the name is already in use in /home/english/public_html/wp-content/plugins/wc-ac-hook/activecampaign-api-php/includes/Connector.class.php on line 8

    • This reply was modified 6 months ago by wandriska.
    wandriska

    (@wandriska)

    Plugin Author equalserving

    (@equalserving)

    Hi,

    Yes, there are other plugins that are using the ActiveCampaign API too and when both are installed on the same site it will generate that error.

    The latest release of our plugin uses namespace to avoid these conflicts. But be warned you must be running PHP version 5.3 or greater to run the latest version.

    Thanks

    wandriska

    (@wandriska)

    I am running Php 7 with your latest version, so, in theory, this problem should not be happening, right?

    Plugin Author equalserving

    (@equalserving)

    Hi!

    I am sorry for the confusion. Our plugin is not throwing that error. The error is being thrown by WC AC Hook plugin and that is why when you disabled it the site worked.

    Because we wanted to avoid conflicts with other plugins that use the ActiveCampaign API, we employed namespaces in the latest version. You probably have another plugin besides WC AC Hook that uses the ActiveCampaign API that is causing the conflict.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Internal Error’ is closed to new replies.