Support » Localhost Installs » Internal 500 error after trying to edit php.ini file in MAMP

  • Resolved bibliofille

    (@bibliofille)


    I was in the process of setting up a local copy of a rather large, like 2GB database, WordPress site that I’m working on. Got the site files setup in MAMP, then went to import the database, and it obviously exceeded the upload limit. So I went into the php.ini file to edit, saved the file.

    As soon as I did that, I started getting internal 500 errors across all my MAMP sites. I can’t currently access any of them.

    I looked in the MAMP error logs and found the following error:

    [Fri Jun 05 12:14:40 2020] [error] [client ::1] client denied by server configuration: /Users/labedzde/Documents/Sites/.DS_Store, referer: http://localhost:8888/MAMP/?language=English

    Can anyone point my in the right direction regarding this error? I’ve done some Googling and fiddling around, but haven’t solved it yet.

    Not seeing anything in wp_debug mode.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Are you trying to import this file using a GUI like phpMyAdmin ?
    Would recommend using mysql command line instead :
    https://stackoverflow.com/questions/17666249/how-do-i-import-an-sql-file-using-the-command-line-in-mysql

    Super easy, and much more reliable.

    Also, why is it trying to write to your .DS_Store directory ?

    Check your httpd.conf file, and your .htaccess file to make sure you are not denying yourself! 🙂
    https://linux.101hacks.com/unix/client-denied-by-server-configuration/

    Thanks so much for the reply @corrinarusso! I actually ended up fixing part of the problem just by updating my version of MAMP. I didn’t think jumping from 5.5 to 5.7 would be such a big deal, but oh well, I was then able to access all my MAMP sites again.

    Yes, I was trying to import the database using phpMyAdmin, which of course failed, so I then tried to edit the php.ini file and that’s where I ran into trouble.

    I will try using the command line instead. Might be the best option with such an enormous database.

    You should always read the changlog before and after updating any application.
    In the case of MAMP :
    https://www.mamp.info/en/release-notes/mac/

    Yes, there should be no issue at all using the command line.

    @corrinarusso Hmm, seems like my database might be even too large to do it this way as well. The database is 9GB.

    I used this command in terminal:

    /Applications/MAMP/Library/bin/mysql -u root -p ab964b9d_6e5f38 < /Users/labedzde/Downloads/ab964b9d_6e5f38.sql

    And I received this error message in response:

    ERROR 2006 (HY000) at line 5253794: MySQL server has gone away

    9 gigs ?
    How is this even possible ?
    I would suggest sorting your original by size, then export tables instead of the entire db.

    @corrinarusso It’s a pretty hefty Woocommerce site. I think there are definitely some

    I tried to find a workaround, using this tutorial , but I couldn’t find where the my.cnf file was in MAMP.

    So it sounds like I may have to chunk it out and export/import a batch of tables at a time?

    You can use spotlight to search for the file.
    Ugh, WooC. Say no more. I dunno, I don’t feel like even WooC could accomplish this.
    I’m guessing there is logging, or caching, or Wordfence type database writing (which you would not need).
    Otherwise, ya – table(s) by table(s). 🙁

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.