• Resolved Candlelite

    (@candlelite)


    I am using your plugin on this website in a number of different forms that use Stripe as the payment gateway to collect debit/credit card payments. I have now had a number of reports of intermittent problems where the form is submitted but then returns a “red bar” at the top of the form with no further explanations – no payment is taken and no email is sent. I have had exactly the same reports from this website https://www.cdts.co.uk/ – this is a Divi template website and https://3ccr.org is a Template Toster bootstrap template – so both different.
    Any help would be much appreciated as customers getting very worried.
    Note I have just updated Forminator to 1.14.12.1 in the hope this will solve the problem.
    Regards Peter

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thread Starter Candlelite

    (@candlelite)

    Hi a bit more information. I have checked the Stripe account linked to 3ccr.org and there are a number of payments shown as Incomplete the reason being PaymentIntent status:
    requires_confirmation. My assumptions is that Frominator is not always sending this confirmation and subsequently fails without any notification other than this blank red bar.

    Thread Starter Candlelite

    (@candlelite)

    Hi I have contacted Stripe about this problem and this is their reply:
    “After carefully checking on the account, the plugin (WordPress Forminator) should be confirming the payment intents here once the customers have processed their payment on their end. Stripe doesn’t know what’s happening with those incomplete payments.
    To check the incomplete payment, I would highly suggest reaching out to your plugin for further assistance.”
    This seems to be a serious problem with the plugin.
    Regards

    Plugin Support Nebu John – WPMU DEV Support

    (@wpmudevsupport14)

    Hi @candlelite,

    I am sorry to know about the issue that you are experiencing.

    Can you please export the form and share it using Google Drive or DropBox so that we can have a closer look at the issue?

    Reff: https://wpmudev.com/docs/wpmu-dev-plugins/forminator/#import-export

    I was able to notice an error regarding the jQuery version used in the browser console. I am not sure but I suspect if that’s causing an issue. Can you please try fixing it and check if that helps?

    Kind Regards,
    Nebu John

    Thread Starter Candlelite

    (@candlelite)

    Hello – I have loaded one of the forms from the website onto Google Drive. Please provide a link so that I can share it with you.
    The theme has been created using an old version of Template Toaster – so I don’t think I can update the jQuery version. However I have also had this red bar problem on another site that uses the Divi template and I assume the jQuery version would be more current.
    Regards

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @candlelite

    Can you send the Google drive links using this:

    Could you please send me an email to contact@wpmudev.org using this template:

    Subject: “Attn: Patrick Freitas”

    Message: Drive Link: https://wordpress.org/support/topic/intermittent-red-bar/

    link back to this thread for reference

    Can you also try some solutions shared on https://wordpress.org/support/topic/red-bar-for-form-submission/#post-14670062

    We do have a reported situation for wp nonce being cached preventing the submission.

    Let us know the result you got on the test.
    Best Regards
    Patrick Freitas

    Thread Starter Candlelite

    (@candlelite)

    Hi I have shared the Google Drive with you.
    I have also changed Validation to Server Side and Rendering to Load form using AJAX. I changed the Mode of payment to Test and the form worked ok – I have now changed it back to Live. However I will keep and eye on this as the problem has been intermittent. When checking Stripe before making these changes I could see another failed payment: Incomplete the reason being PaymentIntent status:
    requires_confirmation. This time for this form: https://3ccr.org/family-group-enrolment/. I hope these two changes have solved this problem.

    Thread Starter Candlelite

    (@candlelite)

    Just to let you know I have checked Stripe this morning after making these changes and there is another failure -so it appears these changes have not resolved the problem. I have checked the server PHP version and this is set to 7.4. My I am using shared hosting supplied by Krystal and I have the Litespeed Caching plugin v3.6.4 installed. However I have excluded all forms from the Litespeed cache.

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello there @candlelite

    Could you please email us a sharable link instead of inviting the contact@wpmudev.org user? We cannot access Google Drive with this email directly and will help to involve more support agents and probably developers as well on this.
    Please use the template shared by my colleague Patrick above, so we get a notification as soon as possible. 🙂

    Thank you,
    Dimitris

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello @candlelite ,

    We haven’t heard from you for sometime now, so it looks like you no longer need our assistance.

    Please feel free to re-open this ticket if needed.

    kind regards,
    Kasia

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Intermittent red bar’ is closed to new replies.