Support » Plugin: Trust Payments Gateway (3DS2) » Intermittent IFRAME “Loading payment details…”

  • Resolved ryangfni

    (@ryangfni)


    Hi Guys,

    My customers checkout IFRAMES are not loading. I have changed some of the settings in the theme regarding jQuery and now getting intermittent loading of the IFRAME, sometimes loads fine sometimes it just sits at “Loading Payment details…”.

    I don’t have any errors in the console or insight into what the problem might be – if you want to get in touch with me I can set you up a sandbox website to test.

    cheers
    Ryan

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor Illustrate Digital

    (@illustratedigital)

    Hi @ryangfni,

    I’m unable to replicate this across a number of tested themes, however if you can send through an email to support@illustrate.digital with details of a sandbox then we can certainly take a closer look.

    Thanks

    Thread Starter ryangfni

    (@ryangfni)

    Hi @illustratedigital,

    I’ve been doing some testing on my core website, (prior to users adding their own plugins) and it works great, I just needed to disable some jQuery optimization settings and it loads every time on checkout.

    I will get in touch with clients that are having issues and pinpoint the offending plugins they have installed.

    all the best
    Ryan

    Plugin Contributor Illustrate Digital

    (@illustratedigital)

    Hi @ryangfni,

    Thank you for the update. I will mark this as resolved for now.

    Hi @ryangfni I wonder if you would share your thoughts on this? I’m using a stock wordpress/woocommerce/hestia install with a variety of plugins and while the iFrame works most of the time, there are occasions when it doesn’t load and any tips from someone who has done the diagnosis would help the rest of us who perhaps aren’t as technically au fait with the inner workings of wordpress.

    Hi @illustratedigital,

    I am facing the same issue but instead of it being Intermittent it is persistent every time. (Using test mode enabled)

    “Loading payment details…”

    The previous plugin was not an issue but as soon as I replace it with the new version of the Plugin, I can not even test it.

    I have seen multiple issues reported since the new plugin was published here and I am wondering what the SLA response time is as some issues/comments appeared to not have responses for 1-2 weeks.

    Tony

    Plugin Contributor Illustrate Digital

    (@illustratedigital)

    Hi @tonyclemmey, we’re not able to replicate this and believe it to be the result of a plugin or theme conflict (this was confirmed to be the case for this thread’s OP). A plugin that modifies scripts (such as Autoptimize) could be causing this error – do you have anything like that installed?

    Please try disabling all plugins (others than Woocommerce and the gateway obviously!) and let us know if that resolves the issue. If it does, we know there is a plugin conflict coming from elsewhere. You could also try the same approach with your theme, switching to a default theme for testing.

    Thanks

    For later reference; when using Autoptimize disabling the option to “also optimize cart/ checkout” should suffice 😉

    Hi @illustratedigital,

    Thank you for the speedy reply and info. I do not use the “autoptimize” plugin, but I do use the “w3-total-cache” plugin just for minify, database and object cache purposes. Page and Browser Cache is not used, instead, Nginx Cache is used but ignored for products/cart/checkout and logged in stuff etc, and Cloudflare is used.

    W3 Total Cache minify would be considered modifying scripts? or the use of the “hide-my-wp” security plugin?

    I can appreciate conflicts do happen, but if we are talking about major top used cache plugins, security plugins or themes it would be disappointing to feel we have to blame the error on those as opposed to questioning Trust Payments compatibility with other top plugins or themes if other payment gateways such as Stripe have no issues etc.

    I have a staging environment behind Cloudflare Access via Github Organization, of which I could grant @illustratedigital access, to look into this issue with the freedom of disabling any plugins or themes.

    Thanks
    Tony

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.