Support » Plugin: Redis Object Cache » Intermittent Error

  • Resolved shapeschicken

    (@shapeschicken)


    Hello,

    We are getting intermittent errors in our logs since implementing redis cache.

    It seems like every now and again it has trouble connecting and results in a 500 error

    1) Is there a way to gracefully fail this without getting a 500?
    2) What is causing the intermittent errors?

    [02-Aug-2021 21:34:38 UTC] RedisException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
     in D:\home\site\wwwroot\wp-content\object-cache.php:636
    Stack trace:
    #0 D:\home\site\wwwroot\wp-content\object-cache.php(636): Redis->connect()
    #1 D:\home\site\wwwroot\wp-content\object-cache.php(485): WP_Object_Cache->connect_using_phpredis()
    #2 D:\home\site\wwwroot\wp-content\object-cache.php(178): WP_Object_Cache->__construct()
    #3 D:\home\site\wwwroot\wp-includes\load.php(701): wp_cache_init()
    #4 D:\home\site\wwwroot\wp-settings.php(131): wp_start_object_cache()
    #5 D:\home\site\wwwroot\wp-config.php(141): require_once('D:\\home\\site\\ww...')
    #6 D:\home\site\wwwroot\wp-load.php(37): require_once('D:\\home\\site\\ww...')
    #7 D:\home\site\wwwroot\wp-blog-header.php(13): require_once('D:\\home\\site\\ww...')
    #8 D:\home\site\wwwroot\index.php(17): require('D:\\home\\site\\ww...')
    #9 {main}
    [03-Aug-2021 01:13:04 UTC] PHP Warning:  Redis::connect(): SSL: Handshake timed out in D:\home\site\wwwroot\wp-content\object-cache.php on line 636
    [03-Aug-2021 01:13:04 UTC] PHP Warning:  Redis::connect(): Failed to enable crypto in D:\home\site\wwwroot\wp-content\object-cache.php on line 636
    [03-Aug-2021 01:13:04 UTC] RedisException: Redis server went away in D:\home\site\wwwroot\wp-content\object-cache.php:640
    Stack trace:
    #0 D:\home\site\wwwroot\wp-content\object-cache.php(640): Redis->auth()
    #1 D:\home\site\wwwroot\wp-content\object-cache.php(485): WP_Object_Cache->connect_using_phpredis()
    #2 D:\home\site\wwwroot\wp-content\object-cache.php(178): WP_Object_Cache->__construct()
    #3 D:\home\site\wwwroot\wp-includes\load.php(701): wp_cache_init()
    #4 D:\home\site\wwwroot\wp-settings.php(131): wp_start_object_cache()
    #5 D:\home\site\wwwroot\wp-config.php(141): require_once('D:\\home\\site\\ww...')
    #6 D:\home\site\wwwroot\wp-load.php(37): require_once('D:\\home\\site\\ww...')
    #7 D:\home\site\wwwroot\wp-login.php(12): require('D:\\home\\site\\ww...')
    #8 {main}
Viewing 1 replies (of 1 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    Redis::connect(): SSL: Handshake timed out

    You can try bumping your timeouts to 3-5s to avoid these errors.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.