Support » Plugin: Calendar Posts » Interfering with the editor?

  • Installing calendar-posts interferes with the WordPress editor on two sites I tried it on. It seems to be messing up Javascript, since functions like inserting a link and tagging no longer work. The little triangle dropdown boxes fail as well.

    I tried it on a fairly basic site with a few plugins as well as a much more complex one. Both running 3.1.3 on Ubuntu. Mac OS X with Safari and Chrome both failed.

    It’s a great plugin, though. I really like the idea!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author swedish boy


    Thanks for the Feedback.
    I will look at it and see what might be causing it.
    Might be a classic jQuery conflict with other plugins/wordpress things.
    What version of WordPress are you using and do you have any jQuery in your theme or plugins?

    Would appreciate if you pasted your <head> tag form one of the sites.



    I’m having the same issue:
    -sometimes can’t write into the post content box in the edit-post page and can’t insert or add tags to posts.
    All this after I’ve upgraded to WordPress 3.2.1 (Italian Version).
    I’ use a (super)modified version of the birdsite theme with the google-repository-version of jquery 1.4.3.
    Tell me if you need some more infos.
    wishing this can help you solve the issue…

    By the way, it has worked very much and very well for me, I used it to schedule posts to my web-radio facebook’s account.
    Anyway thank you very much. (and sorry 4 my poor english)

    Hi, I’ve got the same issue.

    I’m using WP 3.2.1 (FR version).

    When I activate the plugin, the folowing issue appears (and it disappear when I de-activate it), the plugin seems to interact with the post editor :

    1. The WYSIWYG editor’s buttons are not well displayed
    2. The media manager do not open in a modal box (you can use it only by clicking the open in a new tab contextual menu entry).

    Anyway it a good plugin.

    It’s definitely not a plugin conflict – I deactivated all my plugins and it still misbehaved. Perhaps a conflict with the Genesis framework?

    It’s really odd since this happens in the admin/editor, not in the WordPress-rendered site itself.

    The <head> tag is lovely and complex – perhaps I can email it to you instead of posting it here?

    my email user name is stephen and my domain is


    Visual editor buttons are still not working when plugin is active. Any fix soon?

    Hi !

    I’ve fixed the problem by commenting the jQuery loading line in the plugin (it’s allready loaded with the WP admin panel).

    I’ts in the wp-content/plugins/calendar-posts/calendar-posts.php
    line 65
    <!--<script type="text/javascript" src="<?php echo datepick_package; ?>/jquery-1.4.2.min.js"></script>-->

    The best way should be to test if the jQuery is loaded before loading it or not.


    @damien.goubeau – commenting the jQuery loading line worked for me as well.

    line 65
    <!–<script type=”text/javascript” src=”<?php echo datepick_package; ?>/jquery-1.4.2.min.js”></script>–>

    Thanks… cheers’


    Seems this plugin has caused the same conflict for me. I tried the fix you mentioned but doesn´t work for me.

    Its a pity, I really loved what the plu-in does!

    Dear Johan

    This fix works. Good.

    Please update the source code with this simple fix. Every new user will suffer from a broken wordpress install. Remember: release early, release often.
    Cheers, Bar

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Interfering with the editor?’ is closed to new replies.