Support » Plugin: Accept Stripe Payments » Interference with another plugin, Cannot use

  • Resolved harshajayman

    (@harshajayman)


    I really hope you would help me with this issue.
    When I use your plugin it shows the error you have not set publishable key eventhough I have
    I found out the issue a plugin called “jTab Guitar Tab Shortcode” is interfering. When I disable that plugin payment goes through perfectly.
    Problem is I need both plugins badly and there is no alternative to previous plugin.
    Could you sort this out for me please. It is a real help.
    I tried to put the API key in in .js file but I can not find one
    Please help me

    Harsha

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Hi Harsha.

    Looks like jTab plugin is using old prototype.js version, which is incompatible with Stripe checkout. Stripe checkout requires this library to be at least version 1.7.0 (this is not our plugin requirement, this is Stripe requirement), while jTab is using v 1.6.0.1

    However, you can try to replace prototype.js in jTab plugin with a never version. If you go here http://prototypejs.org/download/ , you’ll be able to see some older versions of the library. I tested this one https://ajax.googleapis.com/ajax/libs/prototype/1.7.0.0/prototype.js and it seems that both plugins are working fine with it.

    What you need to do is to replace the file. Download id, then go to your WP installation via FTP, go to wp-content/plugins/jtab-guitar-tab-shortcode/jtab/javascripts/ folder and replace prototype.js with the one you have downloaded. Then test it on your site, it should be working fine.

    Thread Starter harshajayman

    (@harshajayman)

    Wow man worked like a charm
    Thanks a lot and wish you all the best

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Interference with another plugin, Cannot use’ is closed to new replies.