• Resolved roadsunknown


    I have an Integromat scenario with a Webhook receiving data from the WP Webhooks “Send Data on Register” function.

    The hook is successfully connected and data is received, except that the meta_data array is empty. If I try to use a key from meta_data like [meta_data][first_name][1] the result is empty.

    However, if I inspect the data in the queue, the user_meta array has data but there is no meta_data array. But there is no user_meta array defined on the Integromat webhook module so I cannot insert user_meta fields into the module.

    Hard to explain, so here is a screenshot: https://share.getcloudapp.com/jkuQx4Wg

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Ironikus


    Hey @roadsunknown – thank you a lot for reaching out to us, as well as for providing all the details.
    To me it looks like this is an issue with Integromat. Have you tried to simply set up the scenario again?

    If I try to use a key from meta_data like [meta_data][first_name][1] the result is empty.

    In regards to that part of the message, not sure if this actually is an issue here, but since arrays always start with 0, you might want to try [meta_data][first_name][0] in case you call that somewhere as a mapping.

    By default, we send the data over as is – how Integromat handles this data is up to them, but within our payload, everything should be given.

    I hope this helps so far. If you have further questions on that, feel free to let me know. πŸ™‚

    Thread Starter roadsunknown


    Integromat uses the key [1] as the first in an array (yes, confusing for devs but I guess not for the non-coder).

    The odd thing is I have recreated the scenario (no luck). I do have a previous scenario that does display the [user_meta] data but it only appeared AFTER a real record was sent. When just the “Send Demo” test is sent, no [user_meta] so I think it might be an issue with the “Send Demo” record that is used to first define the data structure on the webhook module not including [user_meta].

    Can you confirm when “Send Demo” is sent, it includes the definition for [user_meta]?

    I tested “Send Demo” on Zapier to compare against Integromat. Zapier also does not receive the array for [user_meta] but it does populate [meta_data].

    Plugin Author Ironikus


    Hey @roadsunknown – thank you for the details, I can confirm that this is an issue. Within our “Send Demo”, we are sending over the data with the key meta_data instead with user_meta. I will provide a fix for that with our next version.
    Thank you a lot again for the debugging and your time.
    If you need anything else, feel free to reach out again at any time. πŸ™‚

    Plugin Author Ironikus


    Hey @roadsunknown – I hope you are doing well. Since within the review you wrote within our plugin, you mentioned that the issue was solved, I’m also going ahead and mark this ticket task as resolved too.
    In case you have any additional questions in regards to this topic, feel free to ask at any time, we’re happy to help! πŸ™‚

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Integromat empty meta_data’ is closed to new replies.