Support » Plugin: WooCommerce Stripe Payment Gateway » IntegrationError: It looks like you’re using an older Stripe key

  • Resolved Flyhead

    (@bukers)


    Hello,

    I have regenerated the api keys in my Stripe account admin to make sure they start with pk_live etc but we are still getting this error:
    IntegrationError: It looks like you’re using an older Stripe key…

    Using the latest version of Stripe plugin and WooCommerce.

    No idea what is going on. Please help. Need to resolve this. Our shop is scheduled to go live 19 min ago!

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author royho

    (@royho)

    Hello,

    Can you please go to your Stripe dashboard and on the left menu click on API and let us know which version of the API you’re using?

    Flyhead

    (@bukers)

    Hello,

    It says API version 2017-08-15. However, we did try updating to the newer version and renewed the keys after that. The same errors.

    Plugin Support dougaitken

    (@dougaitken)

    Automattic Happiness Engineer

    Hi there @bukers

    It looks like you’ll need to check your site Content Security Policy:

    Content Security Policy: The page's settings blocked the loading of a resource at self ("script-src https://js.stripe.com"). ...

    You would need to discuss this with your webhost, or look to see if you have a plugin controlling this as it is not part of WooCommerce or the Stripe extension.

    Thanks,

    Plugin Support dougaitken

    (@dougaitken)

    Automattic Happiness Engineer

    Hi there @bukers

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

    Thank,

    wpcodes

    (@codepantry)

    I have this same error

    wpcodes

    (@codepantry)

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.