WordPress.org

Forums

Forms: 3rd-Party Integration
Integrating Listrak (5 posts)

  1. Tiger0915
    Member
    Posted 2 years ago #

    I'm trying to integrate listrak into this plugin, so I get listrak to generate a custom signup form for me, then I pull the url from the "action" parameter of the form, and I use that as the submission URL in this plugin, but for some reason that's not working. None of my test submissions are going through to listrak. Am I doing this wrong?

    https://wordpress.org/plugins/forms-3rdparty-integration/

  2. Tiger0915
    Member
    Posted 2 years ago #

    I mapped the custom form's input values into the values that listrak provided. It's still not working.

  3. zaus
    Member
    Plugin Author

    Posted 2 years ago #

    Sounds like you set up the plugin correctly.

    What does the debug submission (email) look like? It should show a complete mapping of what's being sent to the service, as well as the response from Listrak, which may tell you more regarding the failure.

  4. Tiger0915
    Member
    Posted 2 years ago #

    Here's what I'm getting in my debug emails: http://pastebin.com/21Zf7uXj

  5. zaus
    Member
    Plugin Author

    Posted 2 years ago #

    It tells you the problem in the *** Response *** section (buried within the HTML) - it's missing the email, which you can see from the *** Post (to Service) *** section is the case.

    It looks like you have checked the 'as value' checkbox in the mappings, which is causing it to send the field name you entered (literally, the *value* you entered) rather than the form submission value. Sorry for the confusion.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Forms: 3rd-Party Integration
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags