insufficient permissions to access plugin admin pages (5 posts)

  1. Daniel Llewellyn
    Posted 5 years ago #

    I receive the following error from akismet (and other plugins) when navigating to http://www.example.com/wp-admin/plugins.php?page=akismet-key-config

    You do not have sufficient permissions to access this page.

    My user account has been the original, using a non-standard name, from a fresh install of WP3.1.3 with the only action after install being to import a dumped xml from a multisite install elsewhere into this new singlesite install, assigning all the imported posts to my admin user (as opposed to creating a new user for the imported posts).

    I have tried resetting my plugins dir by renaming away and back again while navigating to the plugins screen between to force deactivation of all plugins.

    Also attempted was creating a temporary admin user, deleting the original admin user and recreating as administrator role. This also did not work. I have tried accessing the admin screen from both the recreated user on the original username and the temporary user before assigning posts across, so the issue is not related to post owner assignment.

    I hope this is enough information to outline the issue. Steps: Fresh install of WP3.1.3 single site, import from wordpress export of a multi site blog, assign posts to admin user during import, activate akismet, receive error when attempting api key config.

    [ edit to point out it's not just akismet ]

  2. Daniel Llewellyn
    Posted 5 years ago #

    ok, it seems to be endemic to my install - a completely different plugin is also causing the same permissions problem.

  3. Daniel Llewellyn
    Posted 5 years ago #

    I can reliably replicate this issue with a fresh install of WP3.1.3 with absolutely nothing changed after the install except to activate the akismet plugin and try to configure it

  4. Daniel Llewellyn
    Posted 5 years ago #

    Some more information about my server setup to help someone reproduce, because I've hit a brick wall:

    default debian 6 squeeze 32bit setup on linode with virtualmin gpl installed via the script at http://software.virtualmin.com/gpl/scripts/install.sh . New website created in apache via virtualmin's web administrartion screen. Virtualmin set php configured to run via a cgi as the website user via suexec. Fresh install of WP3.1.3 downloaded from wordpress.org manually.

  5. jtolksdo
    Posted 4 years ago #

    You need to activate akismet first in the plugins panel. I had the same error yesterday.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Akismet
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic