Support » Plugin: Really Simple SSL » instruction for nginx

  • Resolved kaplan.dani

    (@kaplandani)


    When I install the plugin on nginx base site (nginx –> apache –> wordpress (php-fpm)
    the plugin can’t find the certificate.

    If I use the https address there plugin seems not to work (I have mixed content)

    Is there any specific instructions for this kind of configuration (nginx -> apache) so the pluging can work ?

    btw – changin the site’s url to HTTPS (in settings) breaks the server with infinite redirect loop.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Mark Wolters

    (@markwolters)

    Hi,

    the SSL certificate not being detected indicates a server configuration issue, the location of your SSL certificate can be defined in the server configuration. This is usually causing the issue when a certificate cannot be detected.

    We don’t have any specific instructions on installing an SSL certificate since having a certificate installed is a requirement for the plugin to work correctly.

    If the certificate can be detected but there’s still mixed content, it can help to clear all caches the website uses. For a guide on how to locate mixed content see https://really-simple-ssl.com/knowledge-base/how-to-track-down-mixed-content-or-insecure-content/.

    The plugin will change the site address for you. On some occasions this can result in a redirect loop. For a list of the most common redirect loop causes see https://really-simple-ssl.com/knowledge-base/my-website-is-in-a-redirect-loop/.

    The certificate is installed correctly. when I access the site (https://lp.timedox.us) I can see it is ok – but I have a mixed content issue.
    when I check the SSL in the dashboard – he says there is no ssl certificate.

    Plugin Contributor Mark Wolters

    (@markwolters)

    The site still loads a lot of resources (for example stylesheets) over http://. This causes the site to miss its styling. You can either press the ‘Go ahead, activate SSL!’ button which will update all links to https:// and activate the ‘mixed content fixer’ option in the Settings->SSL->Settings tab to fix this. This will update all links to https://. After clearing all caches the site uses, it should have the secure lock.

    my only concern is when I change (manually) the site’s url to https – I get the redirect loop.
    So if I click this – it will happen as well ?

    Plugin Contributor Mark Wolters

    (@markwolters)

    Pressing the Go ahead, activate SSL! button will also make some other changes to prevent a redirect loop from happening. Since your site doesn’t redirect back to http:// when visited over https:// I don’t expect a redirect loop. It’s possible you have changed the site url to https:// while the home url remained http://. This can be the cause of your initial redirect loop.

    You can read through this procedure and keep it at hand to quickly revert to http:// if a redirect loop does occur: https://really-simple-ssl.com/knowledge-base/uninstall-websitebackend-not-accessible/.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.