Support » Plugin: WordPress File Upload » instance IDs listed in reverse order, editor brings up ID=1

  • airdrummer

    (@airdrummer)


    i hadn’t revisited wfu in nearly a year, but today i find the admin page entirely missing the 6 instances i’d previously created:-\ this is unsat: if u change ur d/b, @least give a migration tool ffs:-\

    furthermore, adding new wfu instances now requires setting the page/post, and they are listed in reverse order of creation. editing any 1 prings up the edit page for ID 1, requiring pulldown selection for desired ID, altho the title remains ID 1:

    Page For Board Members Only: Shortcode Composer for Uploader ID 1
    Generated Shortcode:
    [wordpress_file_upload uploadid=”2″]

    and the target page now contains 2 instances with NO IDs:

    [wordpress_file_upload][wordpress_file_upload][wordpress_file_upload uploadpath=”/Documents/Meeting Minutes”]

    afaiac, this plugin is broken

    • This topic was modified 4 weeks ago by airdrummer. Reason: no preview function
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author nickboss

    (@nickboss)

    Hi, nothing changed in the plugin, in terms of database tables or format.

    Did you change anything in the website? like theme? do you use any page builder? these usually cause the plugin not to display the upload instances.

    This is probably why when you added an instance and you went to the target page it shows more than one shortcodes.

    Regards

    Nickolas

    airdrummer

    (@airdrummer)

    no, the plugin _does_ display the upload instances, but the admin pages do _not_ show the prior instances. nothing’s changed on my end, and u haven’t addressed the titular issues, as well.

    it’s moot @ this point, as my users were incapable of using it anyway when it did work, and i have now disabled it.

    • This reply was modified 4 weeks ago by airdrummer.
    Plugin Author nickboss

    (@nickboss)

    What are the titulal issues?

    titular as in title:
    instance IDs listed in reverse order, editor brings up ID=1

    Plugin Author nickboss

    (@nickboss)

    Ok I got it. Edit the pages manually and delete the additional shortcodes.

    If you want to have two or more shortcodes in the same page, they need to have different plugin ID. If the visual editor does not work, you can change them manually. You need to add pluginid=”2″ or pluginid=”3″ (and so on) inside the shortcode.

    Then I suppose that Main page in Dashboard will display the instances correctly. If not, let me know.

    Nickolas

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.