Support » Installing WordPress » Install/Upgrade from 2.5 to 2.5.1 admin index not accessible

  • Resolved Nihad



    First of all, I am sorry if this issue has be handled already, I couldn’t find it by searching/looking manually.

    I just upgraded from 2.5 to 2.5.1, was prompted to upgrade, which went fine — it completed upgrade process.
    (I even deleted all WP files and copied them all over again, but it still isn’t working.)

    But after upgrade I can’t access index/dashboard page in admin section (wp-admin/index.php) and sub pages that index.php produces.
    Everything else works fine, version has been bumped also.
    Sometimes I can access admin index/dashboard, but only if I leave browser to load the page for minutes at the time. It seems like some of the external links (feeds) are not accessible by servers (yes, tried on several different servers at different locations, so it shouldn’t be network).
    Also, two minutes before upgrade, dashboard worked just find in WP 2.5. Now, 8-9 hours after upgrade, it’s still not working, so I am pretty confident that it isn’t network issue.

    Done some, “low-tech” debugging, and found that it hangs on an if-statement, in wp-admin/menu-header.php

    // Sub-menu
    if ( isset($submenu["$parent_file"]) ) :

    $parent_file holds “index.php” value.
    while $submenu, does not have key named “index.php”.

Viewing 2 replies - 1 through 2 (of 2 total)
  • I am having the same issue, I think. I get the following errors when trying to access the dashboard:

    Warning: main(/homepages/22/d207026515/htdocs/wp-admin/menu-header.php) [function.main]: failed to open stream: No such file or directory in /homepages/22/d207026515/htdocs/wp-admin/admin-header.php on line 69

    Fatal error: main() [function.require]: Failed opening required ‘/homepages/22/d207026515/htdocs/wp-admin/menu-header.php’ (include_path=’.:/usr/lib/php’) in /homepages/22/d207026515/htdocs/wp-admin/admin-header.php on line 69

    And of course, 2 seconds later I get it working… the required menu-header.php file was missing.

    Sorry folks, I’ve figured it out!

    It wasn’t WP 2.5.1 issue, but rather theme related (was using, Tarski theme).

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Install/Upgrade from 2.5 to 2.5.1 admin index not accessible’ is closed to new replies.