Support » Installation » install.php ?

install.php ?

  • <?php
    /** WordPress’s config file **/
    /** http://wordpress.org/ **/
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘blank_wordpress’); // The name of the database
    define(‘DB_USER’, ‘***’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘***’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value
    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = ‘b1’; // example: ‘wp_’ or ‘b2’ or ‘mylogin_’
    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to ‘de’
    // to enable German language support.
    define (‘WPLANG’, ”);
    /* Stop editing */
    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;
    define(‘ABSPATH’, dirname(__FILE__).’/’); (how am i supposed to fill this line out…better example plz)
    // Get everything else
    got these errors when i tried to run the install.php for the first time
    Warning: main(/home/***/public_html/wordpress/wp-includes/wp-db.php): failed to open stream: No such file or directory in /home/***/public_html/wordpress/wp-settings.php on line 30
    Fatal error: main(): Failed opening required ‘/home/***/public_html/wordpress/wp-includes/wp-db.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/***/public_html/wordpress/wp-settings.php on line 30
    I’m pretty sure i just need to fill in the area where i put the bold text…don’t undstand what i need to put there.
    Thnx for all your help..

Viewing 4 replies - 1 through 4 (of 4 total)
  • You do not need to edit wp-config.php except for the 4 details at the top.
    // ** MySQL settings ** //
    define('DB_NAME', 'wordpress'); // The name of the database
    define('DB_USER', 'username'); // Your MySQL username
    define('DB_PASSWORD', 'password'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    WordPress will figure the rest out.
    If you are installing into 2 directories, the check you have followed the correct method:

    nhmm…well i don’t know why i’m getting those errors then…
    all my word press files are saved in the folder “wordpress” which is also in my rott directory.
    does that cause a problem?

    cool…found the problem… for some unknow reason my ftp program(Smart Ftp) miss uploading some files..i’m just guessing that my connection droped during the download…(56k) ;(


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘install.php ?’ is closed to new replies.