Support » Installing WordPress » install.php only opens as a text file

  • I’ve finally gotten mysql figured out and have created a bare database called ‘wordpress.’ The wp-config.php file is where it should be and contains what it ought. Everything appears to be in place. Yet when I try to run wp-admin/install.php through Firefox, the browser just wants to open it as a text file.

    What am I missing? I know PHP and MySQL are functioning; I used phpmyadmin to make the database.

    I’m running Ubuntu 5.04, PHP 4.3.10 and MySQL 4.0.23, and Apache 1.3.33. I’m hosting locally.

Viewing 13 replies - 1 through 13 (of 13 total)
  • (me again): More specifically, Firefox asks me what app to open install.php with or whether to download it. It’s as though Firefox doesn’t recognize the file extension.

    use the internet expl. to set it up see if that helps

    If by “internet expl.” you are referring to Microsoft Internet Explorer, I am afraid that is impossible. As I said above, I am running Ubuntu Linux 5.04.

    Are you saying the other php files are rendered properly while instal.php isn’t? What if you create your own php file file.php contains like

    echo "Hello, World!";

    what happens, then?

    Good question alphaoide.

    Mithrandir – sounds to me like you don’t have the PHP engine installed on your server. Your webserver doesnt know enough to send *.php pages to the PHP engine and instead sends them to your browser…which doesn’t know what to do with it.

    No PHP files are rendered. I think Heatsink may be right. But I have PHP installed, and as far as I know everything is running. index.php in the phpmyadmin directory functions.

    If the webserver doesn’t know how to handle PHP files, how do I fix it?

    Weird. Files in my normal directories don’t get passed to the PHP engine, but any PHP file within the phpmyadmin directory works no problem. I put the wordpress files under the phpmyadmin directory and now everything works. It’s sloppy, and I still want to know how to make PHP take care of ALL files on the webserver, but at least I’ve got this thing sort of working now. If someone can help me with that, I’d start over from scratch and the 5 minute install would actually take 5 minutes.

    As long as whatever time unit it takes is a multiple of 5, you’re still covered by warranty… I think. (Just in case, you should probably send Matt an email. At home. While he’s eating dinner. Okay, maybe not…) Hope you get it fixed soon! 😀

    >Files in my normal directories don’t get passed to the PHP engine,
    >but any PHP file within the phpmyadmin directory works

    Maybe the issue is with the config file.
    It sounds like you set up the phpmyadmin config file ok.
    wp-config.php may have some problem. Yet it’s such a simple file.
    Did you install WP in some other place first? and then move it when you were satisfied?
    I did this once and it didn’t work – in the end I re-installed.

    BTW once you’ve got it sorted out, you might want to put phpmyadmin in a non-default location. I’m seeing probes against phpmyadmin in my logs.

    If there’s a config file making the PHP engine ignore anything that isn’t in /phpmyadmin, where/what could the misconfiguration possibly be? I’m going to look around but if anyone has any idea where I should start, that would be great.

    Hmm. I’ve put hello world and phpinfo() PHP files in each of the directories in question and they work fine. But if I go to wp-admin/ Firefox barfs up a dialog about what to do with a PHTML file. Apparently PHP is humming, but there’s something else amiss. Is there a configuration snag somewhere within WordPress that’s confusing PHP? I hope we can resolve this within the thread in case anyone else comes along with the same issue.

    I’m interested to know what’s going on, too. 🙂
    I once installed the server package bundled with Fedora Core 3. It worked, but it annoyingly, unexpectedly behaved differently than what I expected. I tried to change some server settings but they weren’t applied. I wasn’t sure whether I was editing the wrong files or something was up.
    So, what I did was downloading each apache/php/mysql separately from their websites and installed them manually. Now everything works fine; I know where all the components are installed, where to edit the config, etc.

    My point is, if you installed apache/mysql/php which are packaged with Ubuntu with its some sort of “install package” feature, then try to install them manually.

    That’s all I have to offer. Good luck.

    That might be what I need to do. Currently I’m getting annoyed by some other oddities of this otherwise fantastic distro–and may switch to Mandrake in the end.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘install.php only opens as a text file’ is closed to new replies.