Support » Installing WordPress » install.php not working

  • ok, here is the deal i am new to doing this but fairly smart

    running windows 7
    apache 2.2
    mysql 5.1.44
    php 5.3.2
    wordpress 2.9.2

    apache is working with php for sure as I created the test.php and it spit out the php info

    my old htmlcss.html (web page) file opens in the document root directory and externally using the web url. ( which I am going to be changing to the wordpress , which is what caused this question ) so i know that apache is runing properly

    opened mysql
    mysql>create database databasexyz;
    mysql> CREATE USER ‘userxyz’@’localhost’ IDENTIFIED BY ‘passxyz’;
    mysql> GRANT ALL PRIVILEGES ON dataxyz.* TO ‘userxyz’@’localhost’

    went to the wp-config.php ( opened with notepad)
    located in the documentroot directory specified by apache httpd.conf

    edited the following lines

    define(‘DB_NAME’, ‘databasexyz’);

    /** MySQL database username */
    define(‘DB_USER’, ‘userxyz’);

    /** MySQL database password */
    define(‘DB_PASSWORD’, ‘passxyz’);

    /** MySQL hostname */
    define(‘DB_HOST’, ‘localhost’);

    /** Database Charset to use in creating database tables. */
    define(‘DB_CHARSET’, ‘utf8’);

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘DB_COLLATE’, ”);

    (generated my keys copied and pasted in)

    $table_prefix = ‘wp_’;
    define (‘WPLANG’, ‘en’);

    saved all of my files to the document root directory (minus the wordpress folder)
    then tried to open the install.php file under wp-admin

    “http 500 internal service error”

    What Have I done Wrong Here? or do you need more information.

Viewing 15 replies - 1 through 15 (of 15 total)
  • typo on dataxyz “should be “databasexyz” on grant priv line, was not error during setup but during post only

    discovered the missing ?> in wordpress2.9.2 wp-config-sample.php at download point at the end. from another post this didnt fix my issue though.

    ok , i should start by saying i dont know much about the php language and syntax, i feel there is something wtong with my install.php file, kind of did from the start. here is the text when I open it in an editor. (no editing was done)

    [Mod Note: Chunk of code removed. If you want to post large blocks of code, please use a pastebin.]

    when I opened it it was crammed up onto 7 lines in the notepad, I renamed my install.php install.bak.php.txt and then I created a text file and copied this back into it, this displayed like a proper php file now. same error persists



    Forum Janitor

    Hi. If it’s editing issues, then Wordpad (not word) is slightly better than notepad, downloading Vim for windows might be even better.

    well its not that, I thought i would try other releases, none seem to pass through the install.php file.

    thanx mrmist. but this appears to be somthing with mysql settings i changed localhost to something else and get an error saying it cant find the mysql… so I know its running, just cant figure this out my user name / pass and database are all correct.



    Forum Janitor

    Try turning off fany errors in IE so you can see the real error message, or look at your web server error logs to see more info about the error.

    my server access log – – [14/Mar/2010:12:51:36 -0600] “GET /wp-admin/install.php HTTP/1.1” 500 –

    server error log

    [Sun Mar 14 13:19:27 2010] [error] [client] File does not exist: C:/www/favicon.ico

    sorry i had tried it again later
    here is the error from the right time its the same one but i know how we like to have the exact log

    [Sun Mar 14 12:51:02 2010] [error] [client] File does not exist: C:/www/favicon.ico

    I know this is probably not related but like I said i am new, and its possible

    I read the following :

    Problem: After updating the blog to WP 2.7 everything was running smooth. But when opening some of the plugin setting pages the server responded with a “500 Internal Server Error” – especially when using plugins like “XML Sitemap Generator for WordPress” or when uploading pictures. When I activated the “StatPress Reloaded”-plugin non of the admin section was accessible anymore.

    Diagnosis: PHP is running out of memory.

    Solution: If you are running your own root, dedicated or virtual server this is an easy bugfix: You just have to change the php.ini of your server and provide more memory to your PHP installation. On a shared hosting server – like at the webhosting solutions at 1and1 you often don’t have access to that central php.ini. But there is an easy workaround:
    Create a text file and name it “php.ini” (without the quotes 😉 ) and with a single line of code in it:


    This file has to be placed into the directory /wp-admin/ within your WordPress installation.

    going to try this when I get home….. stuck @ work right now, but if anyone knows something better I am willing to try that also

    as for the favicon.ico error i found
    editing the conf file in apache may fix this
    add the following .

    # Don’t bother looking for favicon.ico
    Redirect 404 /favicon.ico

    # Don’t bother sending the custom error page for favicon.ico
    <Location /favicon.ico>
    ErrorDocument 404 “No favicon

    as always im a noob, this is third hand knowledge….. correct me if you know more about it.

    heh, I know posting my own fixes are lame… but i forget fast, and no one has responded to my post in a while either.

    think I may actually have found the real source of my issue

    Vista Note:
    Because of missing or insufficient write permissions in “C:\Program Files”, we recommend to use alternate folder ( found on another site )

    Windows 7 ( I installed everything to the generic program files (x86) directory. ) Its so new I might just pull it all all the system and start over with a custom directory for all my stuff.

    fixed it myself, downloaded xampp and reinstalled everything….
    now just a theme issue trouble to work through and i am done

    Was experiencing the same problem for days. Finally found a solution here:

    Turns out that you must use instead of localhost in the wp-config.php file.

    Thanks Steve!



    Was experiencing the same problem for days. Finally found a solution here:

    Turns out that you must use instead of localhost in the wp-config.php file.

    Thanks Steve!

    Yes, this is true especially if you’re running Windows 7 OS, haven’t experienced this with Vista but if anyone experiences this with the latter OS mentioned, try this fix first.

    Or you can overwrite the localhost with permanently by editing hosts file at %WINDIR%\System32\drivers\etc\hosts, open up with notepad (run as administrator) and add 1 line that is: localhost

    Or there might already has this line but has been commented out by #.
    Simply uncomment it by removing # and save the file.

    Then it should work with localhost. 😉

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘install.php not working’ is closed to new replies.