WordPress.org

Support

Support » Installation » install.php file displying in browser, not running

install.php file displying in browser, not running

  • Hi there,
    I’m trying to install WP for the first time and I am basically getting the same problem as this person had:
    http://wordpress.org/support/2/13855 .
    What appears to be happening is that if I open install.php on my hard drive in my browser I get just get a page with text and .php code – its displaying the file not running it. If I open the install.php file from the internet I get a ‘Bad Gateway’ error page.
    Any suggestions about where to start sorting this out?
    Thanks
    Ray

Viewing 4 replies - 1 through 4 (of 4 total)
  • if I open install.php on my hard drive in my browser I get just get a page with text and .php code – its displaying the file not running it.

    If you do NOT have your machine installed as a server (i.e. not running apache, php, mysql etc.) then this is the normal way = it cannot “run”. It simply shows the code.
    As for the “internet”, and I think you mean running install.php from/on your hosted domain – I am clueless.

    Hi there,
    This is my question, but I forgot to login………………
    So I need to have apache, php and mysql loaded onto my computer?
    Ray

    Is your site (and your blog) on a hosting provider company’s server? Or you want to have your site running from your own server? In this latter case you need to have all kind of “stuff” but if you don’t know how to do that, better forget it.
    If the whole WP is going to be on a virtual hosting environment, you don’t really need anything on your own box at home.

    Yehaaaaah! Thanks for your advice Moshu, its working!!!!!
    I just got it working 15 minutes ago.
    For some reason the ‘5 minute installation instructions’ supplied by WP didnt quite work.
    {for others who have this problem – I started install.php by visiting my own URL, where there was clickable link and started the installation there}.
    Now it is working great.
    I appreciate your help.
    Ray

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘install.php file displying in browser, not running’ is closed to new replies.
Skip to toolbar