Support » Installing WordPress » install.php comes up blank page

  • When I go to the index page, it gives me:
    [It doesn’t look like you’ve installed WP yet. Try running install.php]
    And when I “Try running install.php” the page comes up, but it is blank.

    I set up my config file and uploaded it with everything else. However, I didn’t know what to do with this part: define ('WPLANG', ''); I didn’t put in a language, because I was hoping it would default to English. Is this my problem? I can’t find documentation or forum reference to this.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    OK, read those. And I even understand some of it.

    phpinfo gives me this :
    Apache/1.3.33 (Unix) PHP/4.3.10 mod_ssl/2.8.22 OpenSSL/0.9.7d

    and MySQL is API version 4.0.18

    and loaded modules includes: mod_rewrite

    I have been running phpbb without any trouble for many moons. I have WordPress installed thusly:
    http://www.maryrobinsonreynolds.com/blog/wp-admin/install.php

    Any help would be greatly appreciated.

    Check the details in wp-config.php again, access your blog’s wp-admin/install.php again.

    With what we have here, it is difficult to guess at why it isn’t installed 🙂

    Mark (podz)

    (@podz)

    Support Maven

    php 4.3.10

    From looking at your blank install.php, I’d say that the problem lies in the fact that the host is running this version of 4.3.10
    Sorry.

    podz: What version would work? The documentation sez: PHP version 4.1 or higher

    2fargon: here is my wp-config.php (with comments taken out – and my MySQL details, of course)
    <?php
    define("DB_NAME", "db_MySQL settings");
    define("DB_USER", "MySQL settings");
    define("DB_PASSWORD", "MySQL settings");
    define("DB_HOST", "localhost");
    $table_prefix = "wp_";
    define ("WPLANG", "");
    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;
    define("ABSPATH", dirname(__FILE__)."/");
    require_once(ABSPATH."wp-settings.php");
    ?>

    Anything wrong here? Do I need to specify a WPLANG?

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Podz, most of us by now (including myself) are running WordPress on PHP v4.3.10. v4.3.10 was released over a month ago to stop those nasty PHP hacks which were occurring over the holidays. Like the ones affecting phpBB and such.

    Mark (podz)

    (@podz)

    Support Maven

    I stand corrected !

    In that case, what program are you using to move the wordpress files from your computer to the site ?

    I am using Adobe GoLive’s internal Publish to Server FTP to upload files.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    ICK! GoLive! ::Hiss!:: Trust me, GoLive’s FTP causes more troubles than it’s worth. We have quite a few “bugs” or “issues” reported with the solution usually being to use something to upload your files other than GoLive.

    For other, recommended FTP apps, see these two links:
    http://tamba2.org.uk/wordpress/ftp/
    http://codex.wordpress.org/FTP_Clients

    OK, I’ll find a better one.

    Should I delete my /blog/ directory and then create the directory again with another FTP client before I re-upload it, or is there more house-cleaning needed before I do that?

    And, thanks everybody…

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Yeah, since you didn’t make any progress, you might as well start over by deleting the files in the /blog/ directory. Remember to delete all of the files before uploading the new ones. Overwriting files via FTP (using any FTP app) can lead to incomplete transfers.

    Thanks one and all.

    I installed FileZilla, deleted and re-uploaded the whole system (using FileZilla instead of Adobe GoLive FTP) and the rest worked as designed. I am up and running.

    Hope I can get to the place where I can be of use to others…

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘install.php comes up blank page’ is closed to new replies.