WordPress.org

Forums

Installing wordpress on WAMP in windows 7 (29 posts)

  1. Dave Bray
    Member
    Posted 3 years ago #

    Hi I installed WAMP using the default settings.
    When I run the wordpress install it opens a web page saying I need to:- 2.Open wp-admin/install.php in your browser
    When I click on wp-admin.php a window pops up saying Do i want to open or save this file so I click on open and install.php opens in Worpad.

    Next it says "1.If for some reason this doesn't work, don't worry. It doesn't work on all web hosts. Open up wp-config-sample.php with a text editor like WordPad or similar and fill in your database connection details."

    What database connections details do I have to put in. Also do I have to pre-configure the WAMP setup in order to have these details?

  2. govpatel
    Member
    Posted 3 years ago #

    You will find article and videos on how to install wordpress in wamp

  3. DaveCoast
    Member
    Posted 3 years ago #

    A couple of items need to be done in order to install.

    1. Download wordpress and know where your unzipped "wordpress" folder is located.
    2. Know where your WAMP document root is - I would expect it to be c:\wamp\htdocs for a default install
    3. copy the wordpress folder to your document root folder and leave untouched (this will be you base to install multiple test wordpress sites).
    3. while in Windows Explorer at c:\wamp\htdocs your should now see a wordpress folder.
    4. make of copy of the wordpress folder which should create a folder named wordpress Copy.
    5. Rename your wordpress folder to you new site test name (something for you to make up) for example testsite1
    6. you should now have a folder c:\wamp\testsite1
    7. Verify your WAMP Apache and MySql servers are active
    8. Go to localhost/phpmyadmin in your browser (or how ever you get to phpMyAdmin in WAMP
    9. in phpMyAdmin Create a new database - your name choice - something like testdb1 (remember this, it is needed for the install)
    10. while still in phpMyAdmin go to databases and click your database
    11. while still in your new database click the Privileges tab
    12 Click add new user - again give any name and password you'd like just remember them (also make sure server is "localhost") - for our example you should have something like user = testuser1 and password testpass1.
    13. ******* now you are ready to Install WordPress *******
    14. In you browser address window type localhost/testsite1/wp-admin hit enter and you should begin the wordpress install dialogue (which should begin with an offer to create your config file - let it and then it will ask for the database info from above.

    Hope this helps.

  4. Dave Bray
    Member
    Posted 3 years ago #

    Hi Dave, thanks for the reply.

    The only htdocs directory I could find in C: was C:\wamp\bin\apache\Apache2.2.21\htdocs

    So I unzipped my downloaded folder wordpress-3.3.1 to
    C:\wamp\bin\apache\Apache2.2.21\htdocs\wordpress
    Should it be in htdocs or one dir up?

    I then copied it to
    C:\wamp\bin\apache\Apache2.2.21\htdocs\testwordpress

    I created a user "admin" in my test "dave" database as you instructed.

    In my I.E. address window I type C:\wamp\bin\apache\Apache2.2.21\htdocs\testwordpress\wp-admin
    and nothing happens.

    If I browse to C:\wamp\bin\apache\Apache2.2.21\htdocs\testwordpress\wp-admin I see a load of .php files.
    If I double click on install.php a wordpad window pops up with its contents.

    If I click on the green W icon in my task window I can see PHP in the list and hovering over the W says the Wampserver is online.

    Do you know what I am doing wrong as I am at the same place I was before?

  5. DaveCoast
    Member
    Posted 3 years ago #

    Dave, I think the confusion it around what the document root means. I would think your WAMP control panel (with the green dots) should show you the current document root.

    Let's assume that it is C:\wamp\bin\apache\Apache2.2.21\htdocs\

    Then that directory will be brought up when you type "localhost" in your browser address bar (like http://www.wordpress.org). If you only type localhost then it will look for something like index.htm or index.php to run.

    So since you installed WordPress in ...\htdocs\testwordpress you would type localhost/testwordpress/wp-admin in your browser. Then once you complete the install you would type localhost/testwordpress to access your new spiffy site.

    I just use sub-directories (like /testwordpress) in my local document root to allow for many test sites. Then I access those sites with localhost/site1 or localhost/site2 etc...

    Does that make any sense?

  6. govpatel
    Member
    Posted 3 years ago #

    In Wamp you will find www when you open your wamp folder and www is your root and the reason we install wordpress in folder is that in www there is index.php file and (you can only have one index file in a folder) that is used for localhost programs

  7. Dave Bray
    Member
    Posted 3 years ago #

    Thanks Govpatel, I moved my wordpress folders from C:\wamp\bin\apache\Apache2.2.21\htdocs\ to
    c:\wamp\www
    Now I can see them as projects when I type localhost in my browser.

    Wehay its working thanks guys.

    My plan is to develop my site locally on my PC then upload it to 1and1 or such like later.

  8. govpatel
    Member
    Posted 3 years ago #

    You are welcome

  9. addboy
    Member
    Posted 3 years ago #

    I have tryed this and I'm getting "Error establishing a database connection" At a loss?
    Thx
    Dave

  10. Elan Technosys
    Member
    Posted 3 years ago #

    @addboy: Check your MySQL server is running and also check database details in wp-config.php and check the data base sexists in your phpmyadmin.

  11. addboy
    Member
    Posted 3 years ago #

    MySQL service seems to be running. Not realy sure how see if the server is running? Ilm trying to runn the word press file to make the config file when I get the error. The data base is in my PHPadmin withe user set up.

  12. govpatel
    Member
    Posted 3 years ago #

    Where exactly have you got your wordpess folder needs to be in www if you using Wamp

  13. addboy
    Member
    Posted 3 years ago #

    Yes it is under the www dir.

  14. DaveCoast
    Member
    Posted 3 years ago #

    If you get the database error from the WordPress Install dialogue, you have it installed in the correct place.

    If you can run phpMyAdmin and see your database then your MySQL server is active.

    Please check the following:
    1. Browse to phpMyAdmin
    2. Click the home icon
    3. Click your database (to be in your database mode)
    4. Click the Privileges button on the top

    You should see your data base user with the following values:
    1. User = the name you gave it
    2. Host = localhost
    3. Type = database-specific

    Can you get this far?

  15. addboy
    Member
    Posted 3 years ago #

    Yes,
    User is the my user name.
    Host is %
    TYpe is Global database-specific

    Is this right?

  16. addboy
    Member
    Posted 3 years ago #

    Got it i found where to change host to local.
    thanks so much.
    Dave

  17. joyanta007
    Member
    Posted 2 years ago #

    I tried all the steps (1-14) and ofcourse using the root dir as "C:\wamp\www". But my problem is different.

    1. During installation process I got this message:

    "All right sparky! You've made it through this part of the installation. WordPress can now communicate with your database. If
    you are ready, time now to…"

    2. I clicked on "run the install"
    3. I filled the installtion form with following information:

    "site title: wpsite
    username: wpadmin
    pass: asdf1234
    email: info@wpsite.com
    privecy: unchecked"

    4. After clicking "install wordpress" it shows only the wordpress title with wordpress logo, everything else are blank.
    (url was "localhost/wpsite/wp-admin/install.php?step=2")

    5. After reloading that page I got this message:

    "Already Installed.
    You appear to have already installed WordPress. To reinstall
    please clear your old database tables first."

    6. I can enter the front end of the site using "localhost/wpsite/" but cant log in the admin panel with that admin user and password which I used during installation.

    I have noticed that the table "wp_users" and "wp_usermeta" remain blank after installation.

    version:
    wamp: 2.2
    wp: 3.4.1

    please let me know what can i do???

  18. govpatel
    Member
    Posted 2 years ago #

    if this is fresh install you can drop all database tables and try to install again.

  19. joyanta007
    Member
    Posted 2 years ago #

    thanks for reply. yes it is a fresh installation. still its not working.

  20. govpatel
    Member
    Posted 2 years ago #

    Then delete the database and wp-config.php file and recreate a database and run install again.

  21. joyanta007
    Member
    Posted 2 years ago #

    its still not working. i removed all database and wp-config.php and tried again. After that i also tried by re installing fresh copy of both wamp and wordpress. but result is same as before.

  22. dterrazas
    Member
    Posted 2 years ago #

    I have my wamp installed and word press running as localhost. Here is my issue. I am using IE9 and FF17 to browse. 7/10 times I have to click on everything twice. Whether it is opening the localhost WP site, phpmyadmin or just clicking around within in the Wp dashboard.

    Anyone ever experience this?

  23. esmi
    Forum Moderator
    Posted 2 years ago #

    @dterrazas: As per the Forum Welcome, please post your own topic. Posting in an existing topic prevents us from being able to track issues by topic. Added to which, your problem - despite any similarity in symptoms - is likely to be completely different.

  24. stevecfischer
    Member
    Posted 2 years ago #

    @joyanta007 I am having the same exact issue. Did you ever figure out a solution? Its a very strange occurrence.

  25. tcw7
    Member
    Posted 2 years ago #

    Jesus...you guys have me SCARED on whether or not i should install it on my machine.

    I've been using it and directly loging in from the wp-admin page with my local service.

    ????

  26. ClaytonJames
    Member
    Posted 2 years ago #

    @tcw7

    It's the dissemination of huge volumes of diverse and often inaccurate information describing unnecessary steps surrounding an otherwise fairly straight forward process that creates that perception.

    In reality WampServer on Win 7 is a piece of cake.

    1) Make sure there are no other installed/running instances of Apache, MySQL, IIS, or php on the machine.

    2) WampServer on Win 7 has a prerequisite of Visual C++ 2010 SP1 Redistributable

    3) This is Optional: Strawberry Perl for Windows if you intend to run MySQL perl scripts on windows.

    Installation steps.

    a) install Visual C++ 2010 SP1 Redistributable

    b) install WampServer, create a WordPress database and user using phpMyadmin (supplied by the Wampserver installation)

    c) download and install WordPress using the published WordPress install procedure, directly to the www directory, which is easily accessible by the shortcut located in the Wampserver system tray icon menu

    d) Apache modules such as mod_rewrite are loaded by accessing the WampServer > Apache > loaded modules menu from the green icon in the system tray. It's as simple as a single mouse click next to the desired module. WampServer even restarts Apache for you.

    - No manual .ini or .conf file configuration is required under normal circumstances.

    Once you muddle through it using the provided tools and easy access configuration menus from the system tray, it very quickly makes short work of setting up a WordPress development environment. It's a lot less complicated than it's often made out to be.

  27. tcw7
    Member
    Posted 2 years ago #

    Thank you Clayton...!

  28. vivek2006munna@gmail.com
    Member
    Posted 2 years ago #

    Thanks, this is very helpful for me...
    I'm also having problem in windows 7 with wamp

  29. lostkiller
    Member
    Posted 2 years ago #

    Hello dave i have done till step 12 and i have created database there and after that it shows the message user name and password is correct but database not found . Plz help me out....

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.