Support » Localhost Installs » Installing wordpress on WAMP gives empty tables only

  • I’m installing wordpress on WAMP and i have problem. nstallation is not completed properly and all database tables are empty ( wp_users are empty ). Not sure how it manages to create tables but not enter data. after last step of wordpress install, page is not loaded completely, it doesn’t say “WP installed and you can now login”. Cannot login(login error). I tried creating new user for database with all privileges and using these details for installation. Still doesn’t work. All database tables are empty, something is preventing entering sample data and I’m not sure what this could be. Wamp server is working ok! (apache and mysql run and work).

Viewing 4 replies - 1 through 4 (of 4 total)
  • There are a few issues this could be cause by…..

    Check the database user has all the privileges in the database . Reapply all privileges and install again.

    What version of PHP you are using? This may be problem with lower version of PHP.

    Hope this helps.

    I have all privileges-Main user but not working///
    Im use PHP 5.4.3 (on wampserver)
    Im dont understand, its created tables but without data inside

    I’ve been struggling a lot with this strange problem, but it seems that it is a time-out issue in PHP. Check your php.ini and do the following temporarily:

    max_execution_time = 240

    It solved it for me!

    I’m having the same difficulty. Tried changing the timeout and db privileges are good. Error logs look okay. Install creates the tables but no data in the tables and the install stops at “step 2”. PHP Version is 5.4.16. I’ve also successfully installed WP successfully on my localhost in the past but maybe not that recently. Any suggestions?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Installing wordpress on WAMP gives empty tables only’ is closed to new replies.