Support » Fixing WordPress » Installing WordPress in non-root directory

  • I just moved old Yahoo Sitebuilder site to Hostgator. I created new WP site on hostgator at I am now trying to get my home domain to redirect to my new WP site. For WP URLs that are unique to new WP site, it seems to work. However, old html pages continue to be shown. Even when I remove the old html files from public directory. Very confusing. I keep clearing cache, but the old files are there. In future, I hope to use redirect plugin to redirect users from old deleted pages to new WP site. I’v edited .htaccess to

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • There’s a Codex article that covers this scenario, and it is available here:

    Please try to follow those instructions and let me know how it goes.



    @mateusgetulio gave you a good reference that you should review but is there a reason you are using a subdirectory?

    I’m only asking because if moving to root is going to help you solve some of your issues and you have limited knowledge, it may just be easier to move your installation to the root using the Duplicator plugin.

    Also, it seems your site is accessible without the ‘www’. If you want the ‘www’ version to work you need to create a CNAME record in your DNS settings. Your host may be able to help you with that.

    Thanks for help. The reason why I wanted WP in separate directory, is that I was not sure how to redirect old HTML pages to their new equivalent (to keep rankings, etc). I was going to use redirect plugin to do that. I thought with old site installed, I could update the redirects one-by-one and test.

    Still working on issue. Really weird results. I moved some old site file out of public_html, yet my browser still finds them afterwards. Even with cleared cache. Maybe I created some kinda circular reference in my .htaccess files in root and wordpress bw directories.

    I just figured out my problem. In in WP General Setttings, I had the site URL as “” instead of “”. It led to very weird results.

    Thanks for the help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Installing WordPress in non-root directory’ is closed to new replies.