Support » Installing WordPress » Installing wordpress

  • Resolved Kittykat12


    Hello everyone,

    I have a problem!

    I downloaded wordpress and saved it on my computer, I created a database on the server, i then edited the wp-config-sample file inputting all the correct database info and saved it was wp-config.php, i then uploaded my files to the server!

    Here is the question.. where should i have uploaded them to on the server??
    I want them to be stored in the root folder, not in any subdirectory like a blog folder.

    I was sure i had it done correctly, but when i type in an 404 error shows up!

    Any one have any solutions?

Viewing 14 replies - 1 through 14 (of 14 total)
  • esmi


    Forum Moderator

    Check with your hosts. Every host is slightly different.


    I checked on the server and the root folder is /webspace/httpsdocs
    I have my wordpress files in this folder, and still nothing comes up.

    I’m thinking i must have missed something along the way. ?

    Hi @kittykat12:

    All files should be uploaded into the public_html folder via ftp so they would work right, did you do that?


    Hi Elmalak,

    Yes i did this with dreamweaver, I put all my wordpress files in a sub-directory called blog. I wonder if something is overwriting it?
    i tried a few different things yesterday and the 404 error still shows up!!

    Hi @kittykat12,
    The is showing the default index.html file that is placed by the server, you need to delete that first.

    Now, I am confused about where you installed WordPress, is in the root folder or in the blog folder?


    Thanks i will delete the file, I had the WordPress files in the root folder,
    But when it didn’t work increased a blog subdirectory, I’d rather if it was on the root folder. So if it works for me I might move it.

    I downloaded worldpress but that seems to be as far as
    i could get. I have HughesNet. Can anyone help me? I tried clicking on the file in the getting started folder and of course it did not work. Not sure how to complete the conf. file for other option.



    Forum Moderator

    @florida View – per the forum guidelines, please start your own thread.

    Hello again, I still haven’t solved the problem..

    I have followed the steps exactly and when it comes to the last step it throws a 404 error!

    I have the blog folder that contains all of the wordpress files in the root folder /httpdocs, there is however another folder within the root folder that is named, should i delete this?

    I created another wordpress last year, its working fine.. so i looked back over that server to see what was different, there didn’t seem to be any other folders on it. so i think i’m gonna delete this folder but not sure if i should!

    any help would be great! 🙂


    I suppose you’re hosting more than one domain name with this account, is that correct?

    If this is the case then you need to move your WordPress files inside of this folder so it would show up when you visit the domain,


    Hi Elmalak,

    No i have just the one domain name with this account, this folder was already on the server in the local root folder for some reason!

    so am i correct in saying that i should move my wordpress files to this folder

    Can you take a screenshot of the ftp structure of your hosting so I can see how it looks and be able to decide on that?

    I need to see the main folders it contains and please, expand the public_html folder a bit to see what’s in it.

    @ elmalak,

    Problem solved! i got it working, just changed the root of the website on the control panel and its working fine, plus i had something slightly wrong with my config.php file!!

    thanks for your help.. 🙂

    Glad it worked.

    Best of luck.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Installing wordpress’ is closed to new replies.