Support » Installing WordPress » Installing WordPress 1.0 on IIS

  • Apologies if this is a redundant topic, but out of all the threads thus far, none have solved my problem and I figured I might as well add to the pile.
    I am trying to get the latest WordPress to install, but I keep getting stuck once WordPress finds my database and attempts to start the install process.
    I’m running Windows 2000 Server with IIS, PHP 4.something and MySQL 3.23. I have created the database, user and password. I have left my permissions wide open for installation (‘Everyone’ has full control, which I guess is CHMOD 777 or something like that in Linux) on the directory for the folder, the database and in IIS. Anyone and anything can write, create and delete files.
    I have edited the wp-config.php file by hand with the needed information and I have also used the form provided to enter setup information (each on different attempts). WordPress tells me that the database is there and it can talk to it just fine (I also did a test of entering erroneous information and WordPress yelled at me. Just wanted to make sure it actually was talking).
    Once past that step, I get the error:
    “It doesn’t look like you’ve installed WP yet. Try running install.php”.
    I get this over and over again. I also get the same errors everyone else gets about wp-config.php not existing, or wp-config.php already being there and if any changes need to be made, delete it and install again.
    Basically, WordPress cannot get to the point of installing the tables in the database and continuing setup. It sees the database and will see the wp-config file, but that’s it, nothing else.
    I have tried with WordPress 1.01 beta, 1.0 and now the nightly build from January 15th. Each time I’ve cleared out my directories and started from scratch. I’ve even tried it directly on the server (it’s my own), but each time I still get the same results.
    Can WordPress not run on IIS? I’ve seen people saying that it can, but hell if it works for me. I also have b2 installed on another site (this is not an upgrade, it’s a fresh install. b2 is on a site that does not touch anything to do with this latest WP install), and it’s been working like a charm for almost 8 months.
    Am I missing a crucial step here? How do I get around this problem? Any suggestions are greatly appreciated.

Viewing 15 replies - 1 through 15 (of 35 total)
  • Have you run the yoursite.com/wp-admin/upgrade.php from your browser yet? I don’t see that in your post.
    HTH.
    Craig.

    Since I was one of the folks who said it’s working fine on IIS, I think I should clarify: I was previously running 0.7x under IIS, then upgraded to 1.0. So, I’ve never actually done a “clean” install on 1.0 under IIS. (I will be shortly, though, as I add another blog.)
    -Tony

    Thread Starter patrickm

    (@patrickm)

    NuclearMoose-
    I am not upgrading from any other build of WordPress or from b2, it’s a clean install with no prior versions. But, I tried upgrade.php anyway just in case something different would happen and I’m still getting the error “It doesn’t look like you’ve installed WP yet. Please run wp-admin/install.php”, which then leads me in circles again.
    tcervo-
    Thanks for the clarification. I’m hoping there is a way to get a fresh 1.0 version on without having to upgrade from any prior build.

    Partick, you should probably grab the 1.0.1 release candidate.

    Thread Starter patrickm

    (@patrickm)

    Thanks. Just downloaded the RC and tried to install and I’m still getting the same problem. Something is being very naughty.

    Another shot in the dark here…when I created my user in MySQL, I forgot to make the user a member of the database. I assume that you have checked this? Dang…we are going to solve this, Patrick…thanks for your continued patience.
    Craig.

    Thread Starter patrickm

    (@patrickm)

    Hey Moose (can I call you that?). I appreciate all the input that is given here and my patience is infinite, no problems there. I just hope my posts don’t get annoying to everyone else. 😛
    The username is actually the administrator of the database, which I know could be a security flaw but I at least know the account has access to everything. I’ve used it on other databases I’ve set up, and it’s worked on all of those.
    It’s gotta be some weird problem where Windows bungles up usage of the config file or something. I’ll stop my guesstimations before I sound too dumb…

    Is the prefix of your database “wp_”? If it is anything other than that, you have to change a setting in your WP-CONFIG.PHP file.
    <pre>
    $table_prefix = ‘wp_’; // example: ‘wp_’ or ‘b2’ or ‘mylogin_’
    </pre>
    HTH.
    Craig.
    PS…call me anything…I’ve been called every name in the book and then some! 😉

    I’m not sure if this is the key, but when you were trying to upgrade from .72 to 1.0, I believe you use upgrade.php, not install.php.

    Thread Starter patrickm

    (@patrickm)

    thanks for the heads up on the typo, scoot. i was using upgrade.php, don’t know why i wrote install.php

    Patrick,
    Here’s my latest advice:
    Place each hand against the edge of your desk.
    Push hard.
    Get up from your chair, and head to the kitchen.
    Open your fridge.
    Grab a bottle of your favourite beverage.
    Turn on some music.
    Sit down on your favourite chair.
    Close your eyes, and sip your beverage.
    Go to your happy place.
    Take your time, and hang out there a while.
    Finish your beverage.
    Belch loudly and rudely.
    Pat your gut in a satisfying manner.
    Set the bottle down.
    Lay back your head again.
    Return to your happy place.
    Bring in through the nose.
    Out through the mouth.
    In through the nose.
    Out through the mouth.
    Okay, relaxed?
    Good.
    Get up and head out to the garage.
    Look for a large hammer or crowbar.
    Head back into your office.
    Smash the living shit out of your computer.
    Leave not a single transistor alive.
    Go back out to the garage.
    Put the tool away.
    Head back to the fridge.
    Grab another sody-pop.
    Jump back into your chair.
    Close your eyes.
    Breath in through the nose.
    Breath out through the mouth.
    Enjoy your beverage.
    Have fun! 🙂
    Craig.

    haha! thanks craig…it’s good advice. i’m definitely done with it for the evening. i think i may crack a beer with my buddy and do some much needed unwinding.

    Thread Starter patrickm

    (@patrickm)

    oops. that was me. ok, now i’m seriously done for the night.

    I’m suspecting the REQUEST_URI variable is not set by IIS.

    Thread Starter patrickm

    (@patrickm)

    um…well, i’m seeing a lot of information on REQUEST_URI and malformed urls with IIS, but where exactly do i alter this? i found a thread regarding ISAPI rewrite (http://wordpress.org/support/3/1523#post-2) and downloaded the lite version (http://www.isapirewrite.com/).
    i haven’t installed it yet, but is this a solution to the problem you mention? or do i alter something within the WP code?

Viewing 15 replies - 1 through 15 (of 35 total)
  • The topic ‘Installing WordPress 1.0 on IIS’ is closed to new replies.