Support » Plugin: EWWW Image Optimizer » Installing pngout

  • Resolved Shyzer


    I’m having a little trouble installing pngout. Despite the fact that I temporarily put wp-content and ewww in 777 chmod, I get an error saying to check the permissions of the ewww folder.

    Next I downloaded the Linux version manually, asked my host which of the versions would work, and they said x86_64 should be the correct version based on the architecture of my CPU.

    So I unzipped the file and manually added pngout-static from the x86 folder to the ewww folder, however it’s still showing up as missing.

    Here’s my debug info:

    Debug Info

    jpegtran path: jpegtran
    optipng path: /home/admin/domains/
    gifsicle path: /home/admin/domains/
    pngout path:
    disabled functions:
    gifsicle permissions: 0755
    optipng permissions: 0755
    wp-content/ewww permissions: 0777
    user: apache
    Operating environment: Linux 2.6.32-279.19.1.el6.x86_64 #1 SMP Wed Dec 19 07:05:20 UTC 2012 x86_64

    Any idea what I’m doing wrong? Thanks a lot in advance!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author nosilver4u


    Looks like you are doing everything right. Ask your webhost if they can test out the pngout-static binary with the -v option to see if it runs at all on your server.

    Thanks for the help! I asked them to do that and was told this:


    It appears that you didn’t chmod the pngout-static file:

    -rw-r–r– 1 admin admin 739504 Feb 11 15:05 pngout-static

    Here it is after we ran chmod 755:

    -rwxr-xr-x 1 admin admin 739504 Feb 11 15:05 pngout-static

    Here is the output:

    # ./pngout-static -v
    Must specify a source or target image
    PNGOUT [In:{PNG,JPG,GIF,TGA,PCX,BMP}] (Out:PNG) (options…) May 30 2012
    by Ken Silverman (
    Linux port by Jonathon Fowler (
    PNGOUT optimizes PNG size losslessly using my own deflate algorithm (not Zlib)
    With the right options, it can often beat other programs by 5-10%. Options:
    -c# PNG output color: 0=Gray, 2=RGB, 3=Pal, 4=Gray+Alpha, 6=RGB+Alpha
    -f# PNG output filter: 0=none, 1x, 2y, 3x&y, 4=Paeth, 5=mixed, 6=reuse
    -d# Override default bitdepth: 0(min),1,2,4,8 (valid only in /c0,/c3 modes)
    -s# Select strategy. 0:Xtreme(default), 1:Intense, 2:Longest Match,
    3:Huffman Only, 4:Uncompressed
    -b# Block split threshold (lower=more blocks, 0=1 block/file, default=256)
    Use trial&error! Suggested values to try are: 0,128,192,256,512,1024,..
    -n# Exact number of Huffman blocks (overrides /b#)
    -r Randomized initial tables (good for many trials with same options)
    -k? 0=Remove optional chunks (default), 1=Keep all
    p=Keep palette indices, s=Keep settings for /c,f,d,b
    -k(Chunk,Chunk,..) Preserve only named chunk(s). Example: -kgAMA,bKGD,tEXt
    -v,q,l Verbose,Quiet,List mode (use ‘-‘ as filename to specify stdin/stdout)
    -y Assume Yes at the ‘overwrite file?’ prompt
    -force Write file even if bigger.
    -mincodes# Workaround for buggy decoders. 1:Zlib 1.2.1 bug, 2:buggy mobiles
    The 1st filename is the input. If you omit the output
    filename, PNGOUT will use the same filename with a .PNG extension. Examples:
    $ pngout inlarge.bmp outsmall.png <- writes outsmall.png
    $ pngout duke3d.png -c2 -f3 -b128 -kbKGD -v <- writes duke3d.png if smaller

    Does that look right? FWIW the error went away on the backend and it’s showing up as being installed. I feel like a knucklehead for it being a simple chmod erro, but I didn’t know I needed to chmod it as well!

    Plugin Author nosilver4u


    That looks fine, so everything appears to be in order. The error the plugin throws is pretty generic, so it probably was having trouble making the file executable itself. I’ll see if I can’t fine tune that some for the next release.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Installing pngout’ is closed to new replies.