Support » Fixing WordPress » Installing plugins in a duplicate folder (from wordpress)

  • Resolved pr0ject10n

    (@pr0ject10n)


    I used the plugin ‘Duplicator’ to duplicate my wordpress folder as two external files (the archive and php installer) and uploaded those into the projectionpictures folder with this path projection (name of the server)/web/projectionpictures.

    I then opended the php file to complete the installation.
    However when I sign into http://192.168.1.234/projectionpictures/wp-login.php and try to install or update further plugins I’m asked to enter connection information for the ftp address of my Synology unit. I’m not sure what the ftp address is but Synology inform me that port 21 is open. I don’t know what the ftp username or password is either, unless I do and don’t realise it.

    What do I have to do now so further plugins can be installed and updated in the newly created projectionpictures as I intend to make it a live site once the plugin problem is solved.

Viewing 15 replies - 121 through 135 (of 153 total)
  • pr0ject10n

    (@pr0ject10n)

    I have solved this TLSv1 enabled with Synology assistance, I had to go into security and change the level of browser compatibility. Mine was set to Intermediate and now its on Modern. That has fixed the TLS issue allow TSLv1.2 from now on. So the warning in whynopadlock has also disapeared.

    I am now asking them about this

    set attrs for /web: permission denied

    as I am unable to reduce it from 777.

    • This reply was modified 11 months ago by pr0ject10n.
    pr0ject10n

    (@pr0ject10n)

    I’ve installed cookie notice by Dfactory and have created a cookie page policy (from https://cookiepolicygenerator.com), but the bootstrap bar doesn’t appear to start with. Unless I’m wrong and it does. I watched a youtube video how to set it up.

    Next I’ve used Health check; Tools to check if the email address for the account will receive one from the website: The email check will invoke the wp_mail() function and check if it succeeds.

    But it failed to send a test email to my yahoo address and get this instead:

    It seems there was a problem sending the email.

    I was trying to use a contact form before on the Contact Us page but it didn’t work in sending me an email so I removed it.

    I’ve deactivated jetpack for the time being.

    • This reply was modified 11 months ago by pr0ject10n.
    • This reply was modified 11 months ago by pr0ject10n.
    • This reply was modified 11 months ago by pr0ject10n.
    • This reply was modified 11 months ago by pr0ject10n.
    pr0ject10n

    (@pr0ject10n)

    I was using the Dfactory but as it didn’t appear to be working I’ve reverted to GDPR Cookie Consent by Webtoffee. When I first installed the plugin/activated it I could see the cookie bar notice. But I’ve only seen it once, even if I use reload on my iphone/ipad or laptop it doesn’t reappear. I also have a this page in place:
    https://www.projectionpictures.com/cookie-privacy-policy/ and that should appear if someone selects the Read More button on the banner. I did a test with cookiebot and it sent me an email to confirm. The domain http://www.projectionpictures.com has been analyzed by Cookiebot to determine if it is compliant with EU regulations on online tracking and is compliant.

    If you visit projectionpictures.com can you see the cookie notice and can you access the policy page?

    With regards to the email issue I’ve opened port 110, 25 and 465 in my router and installed a email plugin for ‘Mail’ in the DSM and in wordpress (WP mail SMTP). Even if I wanted to change the default yahoo email address to my personalized projectionpictures one I’m being blocked, as I haven’t solved the wp_mail function problem. As I’ve had the email function within wordpress working before without having to revert to opening post numbers.

    EMAIL DELIVERY ERROR: the plugin WP Mail SMTP v1.4.1 logged this error during the last time it tried to send an email:

    Mailer: Default (none)
    PHPMailer was able to connect to SMTP server but failed while trying to send an email.
    Consider running an email test after fixing it.

    I had to reactive jetpack as it was affecting the way the youtube links were appearing on my iphone. I only have it working though in its minimal settings otherwise it will knock out the images on the run’n’gun page again.

    • This reply was modified 11 months ago by pr0ject10n.
    • This reply was modified 11 months ago by pr0ject10n.
    Moderator bcworkz

    (@bcworkz)

    Mail server configuration is outside my knowledge base. But AFAIK, it could still be a matter of opening the right ports. Besides what you already have open, to cover the most likely possibilities, try also opening ports 143 (imap) and 587 (smtp). Once you get mail working, consider closing 465 and see if it makes any difference. While it has been commonly used for SMTP in the past, it’s not a standards compliant port for SMTP. It has been reserved for an alternative network communications model called SSM.

    pr0ject10n

    (@pr0ject10n)

    Thank you for heads up on mail port numbers. Will try to configure that later today.

    Any thoughts on:
    Cooke Bar, I was using the Dfactory but as it didn’t appear to be working I’ve reverted to GDPR Cookie Consent by Webtoffee. When I first installed the plugin/activated it I could see the cookie bar notice. But I’ve only seen it once, even if I use reload on my iphone/ipad or laptop it doesn’t reappear. I also have a this page in place:
    https://www.projectionpictures.com/cookie-privacy-policy/ and that should appear if someone selects the Read More button on the banner. I did a test with cookiebot and it sent me an email to confirm. The domain http://www.projectionpictures.com has been analyzed by Cookiebot to determine if it is compliant with EU regulations on online tracking and is compliant.

    If you visit projectionpictures.com can you see the cookie notice and the Read More policy page?

    Moderator bcworkz

    (@bcworkz)

    There’s a cookie notice, but there is no link to the privacy policy page. There is no manual dismiss requirement to confirm a user saw the notice. It automatically disappears once I start scrolling. As a user normally annoyed by these notices, I like that, but I’m not sure it’s a good practice from a legal/liability standpoint.(IANAL) You should be able to see the notice again by clearing the cookie left by your site.

    I don’t have any further thoughts on GDPR and cookie notice plugins. Hard to believe but all the sites I manage do not even drop cookies, much less collect user information.

    pr0ject10n

    (@pr0ject10n)

    Using WP form SMTP I have managed to overcome the WP Mail configuration problem and configured port 587 (smtp) for the outgoing email, I’ve still got 465 open as well. I had to get this setup as I wanted to replace my yahoo email address with my projectionpictures email address as the admin address for the wordpress dash. Which I have now done. Hooray!!!!!!

    You should now find if you visit my site again that the cookie bar appears and if you click on Read More (there will now be a page it turns to see what the policy is). If nothing appears let me know.

    Moderator bcworkz

    (@bcworkz)

    Works perfectly. Awesome!! 😀

    pr0ject10n

    (@pr0ject10n)

    Update from Synology with regards to web/ permission folder access:

    You would need to do this by logging in and connecting as root via SSH.

    https://www.synology.com/en-uk/knowledgebase/DSM/tutorial/General_Setup/How_to_login_to_DSM_with_root_permission_via_SSH_Telnet

    Please be aware that we don’t provide SSH commands.

    The command you would want is something like chmod 775 folder name, though I would advise to create a test folder first.

    I would personally advise not to change the permissions of the web folder, as this can cause irreversible issues with file access by packages and services.

    I replied to them with the permissions/ownership for all folders within web/ and web itself and the numbers for them from filezilla.

    I haven’t used putty yet as suggested in the link. I thought I would ask your opinion first, on their opinion.

    • This reply was modified 11 months ago by pr0ject10n.
    • This reply was modified 11 months ago by pr0ject10n.
    pr0ject10n

    (@pr0ject10n)

    I’ve added recaptacha unfortunately I had to install version 3 not version 2 (which is what I wanted) the one with the tick box on the ‘contact us’ page as I’ve added a ‘contact 7’ form rather than just my info email address. But the recaptcha icon appears on every page of the website, on the bottom right. On a mobile iphone SE screen its very intrusive. How can it be isolated to just the ‘contact us’ page. I’ve seen from various wordpress forums this has kicked up a huge stink. What’s the current solution?

    I did use the keys in the intergration for version 2 but the ‘tag’ recaptcha didn’t appear. It seems since WP 5.1.1 you have to use v3?

    Is there a plugin to control what pages it appears on?

    I’ve decided to disable it until I can control where it appears.

    • This reply was modified 11 months ago by pr0ject10n.
    • This reply was modified 11 months ago by pr0ject10n.
    pr0ject10n

    (@pr0ject10n)

    I have now fixed the version issue of recaptcha by installing yet another plugin called Contact Form 7 – reCaptcha v2.

    I then got another two keys from google recaptcha for version 2 and now have the one I wanted I’ve got now.

    Just need to know which plugin will autoconfigure the sizes for the email, name and message when you see it on an iphone. At the moment the name and email blocks are wider than the message box which does resize itself.

    Moderator bcworkz

    (@bcworkz)

    The overflowing fields is a theme/css issue. You could try adding the following to the Additional CSS panel of the customizer:

    @media screen and (max-width: 425px) {
    input[type="text"], input[type="email"], input[type="url"], input[type="password"], input[type="search"], input[type="number"], input[type="tel"], input[type="range"], input[type="date"], input[type="month"], input[type="week"], input[type="time"], input[type="datetime"], input[type="datetime-local"], input[type="color"], textarea {
        max-width: 100%;
    }
    }
    pr0ject10n

    (@pr0ject10n)

    Is the code below supposed to correct the alignment, dimensions of sizes for the email, name and message entries for the contact 7 form?

    @media screen and (max-width: 425px) {
    input[type="text"], input[type="email"], input[type="url"], input[type="password"], input[type="search"], input[type="number"], input[type="tel"], input[type="range"], input[type="date"], input[type="month"], input[type="week"], input[type="time"], input[type="datetime"], input[type="datetime-local"], input[type="color"], textarea {
        max-width: 100%;
    }
    }

    If the answer to your question is yes, am I meant to enter that text in this screen?
    https://www.dropbox.com/s/umun6nfyz4przvc/ADDITIONAL%20CSS.jpg?dl=0
    on the bottom left relative to the Contact Us screen?

    Moderator bcworkz

    (@bcworkz)

    Yes, I think it will fix the form on phones. And yes, that lower left field is the place to place it.

    pr0ject10n

    (@pr0ject10n)

    OK I’ve put in you code where it should go and it does resize the boxes on an iphone which is great. So thank you for that. I added in a URL website to my form which isn’t mandatory top fill in for anyone who wants to.

    Remember when you asked me about lowering the web/ folder risk from 777 to 775 and filezilla didn’t have permission to do it. Well I’ve had a few correspondence with Synology and here is a there reply. It uses a program called Putty to carry it out. I’ll let you read there short statement, so you can form your own option. As the adviser seems rather circumspect about me doing an alteration.

    I can only advise that the settings are created by default by the Web Station package (for the web/ folder).

    If you wish to change the permissions for better security, you would need to consult a website specialist on what values you should set.

    https://www.synology.com/en-uk/knowledgebase/DSM/tutorial/General_Setup/How_to_login_to_DSM_with_root_permission_via_SSH_Telnet

    Please be aware that we don’t provide SSH commands.

    The command you would want is something like chmod 775 folder name, though I would advise to create a test folder first.

    To answer your question on “you seem unsure of your own advice, don’t seem to want to be specific.”.

    I stated that it is possible to alter them, however I did not say we recommend to alter them and doing so is at your own risk.

    It is not that I am unsure, it is that I would not be able to tell you whether any service would break or not. This will depend entirely on your system, which is unique.

    However if there are any problems, we do strongly suggest to change them back to their original value.

    This was the message filezilla was offering when I attempted to alter web/
    set attrs for /web: permission denied

    • This reply was modified 11 months ago by pr0ject10n.
    • This reply was modified 11 months ago by pr0ject10n.
    • This reply was modified 11 months ago by pr0ject10n.
Viewing 15 replies - 121 through 135 (of 153 total)
  • The topic ‘Installing plugins in a duplicate folder (from wordpress)’ is closed to new replies.