Support » Fixing WordPress » Installing plugins in a duplicate folder (from wordpress)

  • Resolved pr0ject10n

    (@pr0ject10n)


    I used the plugin ‘Duplicator’ to duplicate my wordpress folder as two external files (the archive and php installer) and uploaded those into the projectionpictures folder with this path projection (name of the server)/web/projectionpictures.

    I then opended the php file to complete the installation.
    However when I sign into http://192.168.1.234/projectionpictures/wp-login.php and try to install or update further plugins I’m asked to enter connection information for the ftp address of my Synology unit. I’m not sure what the ftp address is but Synology inform me that port 21 is open. I don’t know what the ftp username or password is either, unless I do and don’t realise it.

    What do I have to do now so further plugins can be installed and updated in the newly created projectionpictures as I intend to make it a live site once the plugin problem is solved.

Viewing 15 replies - 106 through 120 (of 153 total)
  • Moderator bcworkz

    (@bcworkz)

    The img tag’s src attribute is the spinning sun .gif and that is what is displayed, so my browser thinks all is fine. I’m guessing there is some script that should be replacing the .gif in the src attribute with the actual image URL and it’s not working correctly.

    The same effect could be achieved without script by creating an image container and setting its background as the .gif. Then when the image loads it covers the .gif. Of course, the default image insertion routine of the editor doesn’t do this and it would be a pain to set this up manually for every image, so some sort of custom image block would be required.

    The simplest fix is to remove the loading image spinner effect and let images load normally.

    Because WP might alter the contents within the # comments, please move the HTTPS rewrite code outside of the commented area.

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://projectionpictures.com/$1 [R,L]
    </IfModule>
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    pr0ject10n

    (@pr0ject10n)

    Not long after I pasted in the code in the htaccess file (remains in web/projectionpictures folder)I received an email from google search console, with this message inside it:

    New issue detected on https://www.projectionpictures.com/

    To owner of https://www.projectionpictures.com/,
    Search Console has identified that your site is affected by 1 new issue of type Coverage.
    Top errors (5 maximum)
    Errors can prevent your page or feature from appearing in Search results. The following errors were found on your site:
    Submitted URL has crawl issue

    I clicked on a link and its now fixing coverage issues and doing a validation over a few days. Is this good or bad? The IP address for the server has not become secure yet in the URL bar, not padlocked.

    WordPress dash informs me that the automatic update is disabled, not that I would have wanted to do that and I don’t remember disabling it. My guess would be when I was trying to get the folder permissions correct in filezilla using the 3 digit numbers and those changes tend to contradict the categories of permissions used in DSM/File Station. Or it could have been as a consequence of the installation of projectiopictures.

    Projection pictures is working fine on the upgrades/plugins and is already on WP 5.1.1.

    The code at the bottom of the wordpress folder has wp-config file has this:

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    require_once(ABSPATH . 'syno-misc.php');
    
    define(  'AUTOMATIC_UPDATER_DISABLED', true );
    add_filter('pre_site_transient_update_core','__return_null'); 

    The projectionpictures has this:

    /** Absolute path to the WordPress directory. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', dirname( __FILE__ ) . '/' );
    }
    
    /** Sets up WordPress vars and included files. */
    require_once( ABSPATH . 'wp-settings.php' );
    //**The next line allows direct downloads*/
    define('FS_METHOD', 'direct');

    I added the last two lines in projectionpictures when I was installing with the 5 minute guide.

    What do we have to do to the wp-config for wordpress to enable WP 5.1.1 to install in wordpress folder?

    Thank you for your explanation of the spinning sun .gif.

    You said:

    The simplest fix is to remove the loading image spinner effect and let images load normally.

    That sounds great ! How do [we] I do that as the image at the top of the camera appeared intermittently, I removed them for the time being. Why though do all the images appear without a problem on the wordpress/run’n’gun (can you see that page, I supplied a link before?) – I find that very odd !

    If I manage to fix the wordpress update I’ll leave a subsequent update after this entry if its no longer allowing me Edit this one.

    • This reply was modified 1 year ago by pr0ject10n.
    • This reply was modified 1 year ago by pr0ject10n.
    • This reply was modified 1 year ago by pr0ject10n.
    • This reply was modified 1 year ago by pr0ject10n.
    pr0ject10n

    (@pr0ject10n)

    UPDATE—– UPDATE—–UPDATE—– UPDATE —–UPDATE—– UPDATE —–UPDATE.
    I removed:

    define(  'AUTOMATIC_UPDATER_DISABLED', true );
    add_filter('pre_site_transient_update_core','__return_null'); 

    From its entry in the wp-config in the wordpress folder. This has allowed it to accept 5.1.1.

    So please read the previous posting but ignore the section about this matter. So we can concentrate on the Google console email and the image page problems. One other thing in the Google console for the website, the ‘crawl issue’ started 2 days ago on 12-3-19, so not directly connected to the recent htaccess change done this evening.

    • This reply was modified 1 year ago by pr0ject10n.
    • This reply was modified 1 year ago by pr0ject10n.
    Moderator bcworkz

    (@bcworkz)

    Access via IP does not result in a padlock? The 192.168.1.234 IP? I wouldn’t worry about it. That is a local LAN IP. No one outside yoru LAN can use it. It’s probably related to the lack of SSL certificates for IP addresses. When I access projectionpictures.com it shows a green locked padlock, so I’d say everything is OK.

    I’m not sure what the Google Console errors mean. They are things to address in order to maximize your search ranking.

    It’s hard to say what the root cause of image problems is. Something about the script that first puts the spinner .gif in place for images, then subsequently replaces with the original image. It’s failing to do the second part. The easiest fix is to remove the script so it does not even place the spinner .gif to start with. Unfortunately, I couldn’t tell you which script that is. You could selectively deactivate plugins in turn until the spinners disappear. See if you can do without the responsible plugin. If no plugin is responsible, then it would be your theme. See if there is a setting to turn spiinners off somewhere if that’s the case. Same goes if it’s a plugin you cannot do without.

    pr0ject10n

    (@pr0ject10n)

    I found the plug in problem it appears to be jetpack. You can complete the setup where it links my site with wordpress.com and be approved. Choose the kind of site I have, go with a free plan, if I activate recommended feature, it knocks out 2 of the three images on run’n’gun. If I go into settings it appears that I can enable site accelerator and the two toggles directly beneath it. However if I switch on

    Enable lazy loading for images, that alone stops them appearing.

    Which is why the wordpress folder didn’t have this issue as Jetpack only works as on a live site, as far as I am aware.

    As of publishing this entry the permission numbers for projectionpictures are its folders are on 755 (except wp-content is on 775 and the sub folders therein) and all the files are all 660. Admin is the owner, with Admin with Read and Write (Not Del), http (multi) Read and Everyone Read

    If for any reason my assessment of that changes I’ll do an update.

    Question for you, throughout the time the images were an issue I was trying to get a simple email entry form working on Contact Us page. Using WP forms lite or Add form Contact. There isn’t much to it, to get it configured (I had it working last time before the site got a virus). What category of permission must the projectionpictures have for someone to enter there name and email address in those boxes, so that I receive an email as a consequence of them pressing ‘send’ as I’ve been doing tests, where the green box appears underneath to acknowledge the message was sent but I’ve not received the email.

    • This reply was modified 1 year ago by pr0ject10n.
    • This reply was modified 1 year ago by pr0ject10n.
    • This reply was modified 1 year ago by pr0ject10n.
    Moderator bcworkz

    (@bcworkz)

    Ah, jetpack. I didn’t recognize it’s lazy image loading traits because I don’t use jetpack.

    I would expect your NAS does not have a mail server active, so it’s not able to send out emails. You need something like Mercury Mail running for emails to go out. Alternately, configure the wp_mail() function to dump messages normally sent out to a log file. You’d then have to periodically check the file for new messages.

    Yet another option is an extension plugin for Contact Form 7 that saves message submissions to the DB instead of emailing. It provides a backend UI for reading messages, sort of like how post comments would be checked. There are a couple different options in the WP repository: https://wordpress.org/plugins/search/contact+form+db/

    pr0ject10n

    (@pr0ject10n)

    In answer to:

    I would expect your NAS does not have a mail server active, so it’s not able to send out emails.

    Yes it does but only if you install it:
    https://www.synology.com/en-uk/knowledgebase/DSM/tutorial/Collaboration/How_to_set_up_MailPlus_Server_on_your_Synology_NAS

    Just so you know before I had to start (thinking) there was something wrong with the folder permissions for projectionpictures with regards the image issue, WP Form did actually work, as I had it up and running and sending to the default admin email address for the wordpress dash, a yahoo address and to a projectionpictures email address. I’ve never yet had to resort to installing a Mailplus user app in the DSM and didn’t know there was one. Now I do. So thank you for that. I’ll see if I can persevere with WP forms or Add form Contact (which appears to have been included with wordpress to start with).

    • This reply was modified 1 year ago by pr0ject10n.
    • This reply was modified 1 year ago by pr0ject10n.
    Moderator bcworkz

    (@bcworkz)

    The mail server on your NAS could be much like other computers that come with a bunch of apps pre-installed. If you were to format the disk on such a computer, you would need to re-install the all of the apps you wanted even though you never had to install them before. IDK, just speculating.

    There is no WP Forms feature in the default WP distribution as downloaded from this .org site. It’s not uncommon for hosts to add features to the installation that they provide to their customers. Perhaps Synology does something similar? Regardless, it is apparently included with the package you are using. It wouldn’t be that unusual.

    There is a wide variety of form plugins available in the .org repository and several outside of it. I’m not sure, but I would guess that Contact Form 7 is the most popular from the repository and Gravity Forms the most popular commercial plugin. This is not an endorsement and does not necessarily speak to the quality and usability of these plugins, only that a lot of people use them. Infer from that as you wish πŸ˜‰

    pr0ject10n

    (@pr0ject10n)

    Thank you very much for all your assistance. I will now try to work out why the wp forms contact template configuration isn’t working so far for me. I may contact them if I am unable to sort it myself.

    I have a projection.synology.me cert in place from lets encrypt but the the https version of the DSM login isn’t working even though I have all green ticks from whynopadlock and I have the variants in web station. I’ll get onto synology technical support when there customer support is back on online.

    Moderator bcworkz

    (@bcworkz)

    You’re welcome.

    If you click the info icon where the padlock appears and the cert data is in order and up to date, the most likely cause of padlock failure is mixed http/https content on the page. Check the network tool in the browser’s developer tools bundle to see what other content is being requested and under which transport. Or wait for their customer support πŸ™‚

    pr0ject10n

    (@pr0ject10n)

    Is there a wordpress plugin that allows you to limit or remove the amount of autosave you have per page that have been created?

    I found a page for entering code into the wp-config php.
    https://www.wpkube.com/how-to-disable-post-revisions-in-wordpress/

    Still waiting on synology to get back to me about the https SSL mismatch.

    • This reply was modified 1 year ago by pr0ject10n.
    Moderator bcworkz

    (@bcworkz)

    You could try some of the ones at https://wordpress.org/plugins/search/revision/

    I’ve always just used the wp-config.php definition methods.

    pr0ject10n

    (@pr0ject10n)

    Synology came back with this reply with regards to the https SSL certificate mismatch. Do you agree with their assessment?

    Hello,

    Thanks for getting back to me and providing additional information.

    This error will not occur when connecting to your NAS via HTTP and it is an expected consequence of navigating to a local IP address via HTTPS connection.

    All modern browsers will warn you when connecting to a local IP without a valid security certificate when using a HTTPS connection and this is the case with any local device.

    This is because certificates are used to validate the identity of a domain, and local IP addresses cannot be verified in this same way using Let’s Encrypt.

    Your Let’s Encrypt certificate is valid when browser to your DDNS only:

    https://www.dropbox.com/s/q9odq6gceefvsv3/synology%20jpeg.jpg?dl=0

    If you are only using your NAS on your local network via the local IP, HTTPS traffic is not necessary (your router protects your local network) and this error can be safely ignored through your browser using the continue options you have pictured.

    Kind Regards,

    Filip

    Moderator bcworkz

    (@bcworkz)

    Yes, that is correct. I didn’t realize previously you were using a LAN IP address. Local IPs are not unique, anyone can have one on their LAN, so there is no way to certify ownership. Thus any attempts at certification must be invalid and the scary insecure warning gets displayed with HTTPS requests. It’s kind of pointless accessing a LAN IP with HTTPS.

    pr0ject10n

    (@pr0ject10n)

    Is it strictly necessary for me to do anything about this:

    You currently have TLSv1 enabled.
    This version of TLS is being phased out. This warning won’t break your padlock, however if you run an eCommerce site, PCI requirements state that TLSv1 must be disabled by June 30, 2018.

    And how do I do this?

    • This reply was modified 1 year ago by pr0ject10n.
Viewing 15 replies - 106 through 120 (of 153 total)
  • The topic ‘Installing plugins in a duplicate folder (from wordpress)’ is closed to new replies.