Support » Installing WordPress » Installing PhpMyAdmin on remote server, and then WordPress

  • Resolved evuki


    I’m slowly losing my mind over this (1st day in this).

    So, I have a site, bare naked thus far, you only get hosting service information when you open it. Its control panel has ability to add new databases, but no phpMyAdmin, which I decided to install manually, and then install WordPress using that.

    But, how? I used Filezilla to transfer contents of phpMyAdmin folder I downloaded and extraceted from my Desktop to the root folder of the site, but I get 404… Obviously I have to create some kind of database and user, but I’m lost.

    Please help? It’s quite urgent…

Viewing 11 replies - 1 through 11 (of 11 total)
  • What host are you using. You don’t really need to use phpMyAdmin to install WP you could just make the database then use the WP installer to handle the rest.

    I am fairly sure that most hosts (unless you have a vps or something similar) will not allow installs of phpMyAdmin.

    Just found out an older version of phpMyAdmin buried somewhere in the control panel, and I’ve made the database, made the user, edited config.php and uploaded wordpress folders and filed, but is 404… Any suggestions?

    What happens you go to, I normally make a database and user then upload the WP files and go to and use the auto installer.

    If you are getting a 404 that means the page is not there, Check your directories and makes sure that WP is in the /public_html or /www folder.

    I checked hundreds of times, but I think the problem lies in the DB_HOST line in config.php… It doesn’t work with the usual ‘localhost’ value…

    Is the mySQL server on the same box or on another. A simple way to check would be to put the code below in a php file and open it from your browser.

    $con = mysql_connect("localhost","username","password");
    if (!$con)
      die('Could not connect: ' . mysql_error());
    echo 'Connected';

    Did what you said, got 404 again…what does that tell me?


    Wrong directory
    .htaccess blocked
    no read permissions

    Sounds like you might be putting the files in the wrong directory. They need to go in the folder configured as the web root in the web server, not the root folder of the server.

    I think I did alright there, I put them in ‘wwwroot’ folder, it’s said to put stuff into that folder so others will be able to see it… There’s only ‘db’ and ‘logs’ folders beside that.

    Can you access html files in the wwwroot folder? Has the domain name propagated through the DNS system yet?

    Yes. But it appears my aunt bought the cheapest package, with actually no support for php/mysql. Didn’t know there could exist such a piece-of-crap option. Resolved, I guess…

    Thank you very much, though 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Installing PhpMyAdmin on remote server, and then WordPress’ is closed to new replies.