Support » Installing WordPress » Installing Network on IIS8.5 hosted site

  • Resolved beggemey


    Installed a fresh install of wordpress on an IIS 8.5 server. I followed the instructions here: When I finish the install by copying the new code into my web.config file, sign out and back in. The “My Sites” link does not show up in the dashboard. However, when I click on network setup under tools it says “warning: an existing wordpress network was detected.” I have read that the automatically generated code isn’t always correct. Here’s the code it generated.

    "<?xml version="1.0" encoding="UTF-8"?>
                    <rule name="WordPress Rule 1" stopProcessing="true">
                        <match url="^index\.php$" ignoreCase="false" />
                        <action type="None" />
                    <rule name="WordPress Rule 2" stopProcessing="true">
                        <match url="^wordpress/([_0-9a-zA-Z-]+/)?wp-admin$" ignoreCase="false" />
                        <action type="Redirect" url="{R:1}wp-admin/" redirectType="Permanent" />
                    <rule name="WordPress Rule 3" stopProcessing="true">
                        <match url="^" ignoreCase="false" />
                        <conditions logicalGrouping="MatchAny">
                            <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
                            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
                        <action type="None" />
                    <rule name="WordPress Rule 4" stopProcessing="true">
                        <match url="^wordpress/([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*)" ignoreCase="false" />
                        <action type="Rewrite" url="wordpress/{R:1}" />
                    <rule name="WordPress Rule 5" stopProcessing="true">
                        <match url="^wordpress/([_0-9a-zA-Z-]+/)?([_0-9a-zA-Z-]+/)?(.*\.php)$" ignoreCase="false" />
                        <action type="Rewrite" url="wordpress/{R:2}" />
                    <rule name="WordPress Rule 6" stopProcessing="true">
                        <match url="." ignoreCase="false" />
                        <action type="Rewrite" url="index.php" />
    • This topic was modified 3 weeks ago by  Steve Stern.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Is the above code correct for enabling network on an IIS web server? I have been researching this for 2 or 3 days and haven’t found a solution that works.

    This problem was entirely caused by me. For some reason I moved the following lines to above the “That’s all, stop editing!” line in the wp-config.php. Moving them back to the bottom of the file where they belong fixed the problem.

    /** Absolute path to the WordPress directory. */
    if ( !defined(‘ABSPATH’) )
    define(‘ABSPATH’, dirname(__FILE__) . ‘/’);

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‘wp-settings.php’);

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.