Support » Installing WordPress » Installing error: “failed to open stream”…Um, HELP?

  • Greetings, I’m new to WP and also to MySQL. I’ve tried to install WordPress various times and each time my attempts are foiled. I’ve searched the ‘installation’ DB of questions here, and although I’ve come across some with similar problems, none of their solutions seem to work for me. So I thought I’d post, myself…

    First I’d like to know if my host has set up what needs to be done – no sense go through the installation if the DB wasn’t set up properly. I was provided with DB username/DB password/DB name/and host.

    I’ve posted a few desktop captures of my phpMYAdmin control panel to give you an idea of where I’m coming from:

    I have followed the instructions for installation to a tee. I have all the DB username/DB password/DB name/and host filled in wp-config.php. I’ve uploaded everything to my domain (in a separate “wordpress” directory). I’ve tried to install by going to For the sake of installation ease, I’ve set all the permissions to the highest they can go – so the permissions are obviously not the problem in this case.

    Here is the error message I get every time…

    Warning: main(/usr/home/sites/ failed to open stream: No such file or directory in /usr/home/sites/ on line 87

    Fatal error: main(): Failed opening required ‘/usr/home/sites/’ (include_path=’.:/usr/local/share/pear’) in /usr/home/sites/ on line 87

    I am so DETERMINED to get it to work! Can somebody pretty-please lend me some of their WordPress installation wisdom?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Try to upload a fresh version of the functions.php (or the whole includes directory, if that’s easier.)

    Thanks for the reply.
    Actually the entire download of WP files was done just a few minutes before I attempted to install it. 🙁

    But I will indeed try it again….

    Most excellent! Thank you so much. Your advice helped me, and it seems to be working.

    For those of you out there who are having similar problems – function.php failed to extract into my WordPress folder for some reason – so check for the file in specific that seems to be the problem. It was missing entirely. How odd!

    Thank you again and again!!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Installing error: “failed to open stream”…Um, HELP?’ is closed to new replies.