Support » Fixing WordPress » installing a plugin, directory not writeable, perhaps default path

  • Resolved pleur21



    I am new to wordpress, and installing a plugin is failing with this error :
    ‘Downloading install package from…

    Unpacking the package…

    Could not create directory. /wordpress/wp-content/upgrade’

    This is the incorrect path. The path should be /opt/wordpress/wp-content/upgrade
    That is because wordpress is installed in that path on the computer (server).

    I am using Ubuntu Linux 12.10, WordPress 3.4.2 and XAMPP (recent version this week) for this, and I have tried several things including editing the wp-config.php and wp-load.php files to define the ABSPATH variable to be ‘/opt/wordpress’ and as well as adjusting permissions in the wordpress folder and all subdirectories and files (using chmod -R) to be 777. I have also changed the owner of the wordpress folder and all subdirectories and files (using chown -R) to be ‘www-data’.

    I have also tried manually installing the plugin. Using a .zip file has a similar error with creating a directory, although this time it is :
    ‘Unable to create directory wp-content/uploads/2012/11. Is its parent directory writable by the server?’

    I noticed there isn’t a ‘/’ at the beginning of that error message, so I am not sure why it is getting that error.

    Also, I have tried a manual install, by unzipping the contents of the plugin into the ‘/opt/wordpress/wp-content/plugins’ directory to no avail. For some reason, the plugin, after this unzipping, is not listed in the plugins section after logging in as admin. The php file has the appropriate header comment, but it is still not listed.

    Any help would be *greatly* appreciated. Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Also, since I will be developing a plugin for wordpress, I am particularly interested in getting wordpress to notice a new plugin in the plugins directory, as this will allow me to do development work. I have written a “Hello World” php plugin, but just as with the Formidable plugin manual install, wordpress is not recognizing it.

    So maybe the question is, How do I get WordPress to recognize a new plugin?

    The two default plugins, “Hello Dolly” and “Akismet”, are recognized. I am not sure why.


    This issue has been resolved.

    If anyone is having a similar issue with xampp or lampp, please realize that going to http://localhost/wordpress ACTUALLY goes to the wordpress install that lampp does, not the wordpress that YOU install. This confused me, so all the changes I made to wordpress didn’t do anything because I was modifying the wrong wordpress install.

    I guess I never realized this obvious problem because I ASSUMED that lampp didn’t install wordpress and that my install was the one it referenced. In retrospect, it is quite obvious http://localhost/wordpress would NOT go to /opt/wordpress without some customization.

    If you have this issue, the wordpress install by lampp is at : /opt/lampp/htdocs/wordpress (which is a better spot for a wordpress install anyways)

    What a relief to be able to get to work.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘installing a plugin, directory not writeable, perhaps default path’ is closed to new replies.