Support » Installing WordPress » Installing 2nd copy of wordpress w 2nd database

  • Resolved ajtoth91

    (@ajtoth91)


    PROBLEM:
    I get a wordpress critical error when trying to use the wp-install.php, and cannot complete installation.

    Steps so far:
    1. text-edited the wp-config-sample with a database name, user/pass, database prefix. Tried with both new salts and salts identical to my existing /wordpress/ installation
    2. Used phpMyAdmin to create a new portfolio database, took the existing wordpress_user and added all their permissions to the new portfolio database.
    3. wp-admin/config.php identifies when wp-config.php exists

    Other deets:
    Methinks its some permissions error? I’m not sure which permission for which user, but here’s why I think that is.
    -If I don’t have a wp-config.php, and I run setup-config.php, it throws a critical error after I fill in all the information.
    -If I do have a wp-config.php and I run setup-config.php, it knows the file exists. When I run wp-admin/install.php, it throws a critical error.
    -Changing the http group from Read-Only to Read-Write didn’t change anything. (Even after clearing cookies/cache)
    -There’s only one MariaDB user: wordpress_user, and I gave all permissions to both the wordpress and portfolio databases. FWIW: The portfolio database has no tables. Created it from scratch through phpmyadmin, like the install instructions recommended.

    Current Situation
    And now when I try to open the main page: ajtoth.synology.me/portfolio, (I turned debugging on in the config) I get the following error
    Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /volume1/web/portfolio/wp-includes/wp-db.php:1785 Stack trace: #0 /volume1/web/portfolio/wp-includes/wp-db.php(724): wpdb->db_connect() #1 /volume1/web/portfolio/wp-includes/load.php(561): wpdb->__construct('wordpress_user', '#####...', 'portfolio', 'localhost:/run/...') #2 /volume1/web/portfolio/wp-settings.php(124): require_wp_db() #3 /volume1/web/portfolio/wp-config.php(96): require_once('/volume1/web/po...') #4 /volume1/web/portfolio/wp-load.php(50): require_once('/volume1/web/po...') #5 /volume1/web/portfolio/wp-blog-header.php(13): require_once('/volume1/web/po...') #6 /volume1/web/portfolio/index.php(17): require('/volume1/web/po...') #7 {main} thrown in /volume1/web/portfolio/wp-includes/wp-db.php on line 1785

    Google suggests it has to do with define(‘WP_USE_EXT_MYSQL’, true); or define(‘WP_USE_EXT_MYSQL’, false);
    Tried both; no luck. Now I’m really out of ideas.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.