Support » Plugin: Duplicator - WordPress Migration Plugin » installer.php downloads instead of running the installation

  • Resolved JohnMaskell



    Duplicator question.

    Why is it that when I navigate to the installer.php file in the browser to install the Duplicator package, the browser downloads the installer.php file instead of opening the installer?

    The default text editor opens the file as well. I see no option to negate this.

    I have done this so many times, and now, all of a sudden, the installer.php file downloads instead of running the installation package.

    How do I fix the issue? Ideas!


Viewing 15 replies - 1 through 15 (of 16 total)
  • Hi,

    I am having exactly the same problem trying to clone a site hosted on mediatemple (gs) for editing on a localhost.

    I have successfully used it for sites on other hosting providers.

    I’ve tried some of the fixes suggested in other threads (using the developer’s version of duplicator for instance), but the error still occurs. It’s getting very frustrating. Any advice would be greatly appreciated.


    PS I have contacted media temple and they could not identify any problem on their end.

    Plugin Author Cory Lamle


    Hey John,

    I have seen this issue on rare occasions and I believe that you PHP processor is not honoring the GET vars. The only way on your particular sever to circumvent the download logic is to comment it out.

    Open the installer.php and comment out lines 24 through 68 this will prevent the download logic from happening…

    Hope that helps!

    Hi lifeinthegrid,

    Thanks for your response… but it didn’t solve my problem. I commented out 24-68 in the installer and saved the new version before running, but after I run “deploy” in the installer window, it hangs between deploy and update and still tries to download the installer.php file.

    It seems to go through the deploy process, but then I just get a blank white window under Step 1: Files and Database and “update” is still grayed out.

    At least some of the files were downloaded to localhost, but if I try to access any of the php files, /localhost/site/wp-login.php, for instance, the browser also tries to download them. I can access .html and .css files through the browser after the incomplete deployment.

    Again, this site is on mediatemple (gs) if there are any known issues with them.



    I did comment out lines 24-68, ran the installer, nothing happened…just a white screen.

    I reverted the commented-out lines, ran the installer, which ran up to the point of unpackaging the WordPress installation then stopped after the ‘installer.php’ file was downloaded to the desktop. Coda opened the files by default after download.

    Tried navigating to wp-admin after that, but another .php file (BODmwAdc.php)was downloaded.

    Tried running the installing the other way to my Mac and Mamp. I get the same result. Bizarre!

    Plugin Author Cory Lamle


    Hey Guys,

    These both seem like really bizarre behavior I’m wondering if something is configured with Apache or PHP that is causing these irregularities.

    You might try and grab the developer version. It has some additional functionality that lets you pull jQuery from a CDN vs being embedded in the installer. I don’t think its related to your issue but you could give it a try…

    To get the Developer Version follow these instructions:

    -> Browse to
    -> Look for the section “Other Versions”
    -> Click on “Development Version” and download the zip plugin file
    -> Uninstall your current version and install this one
    -> Note: The version number might still be the same but the source code is different.

    Not sure what else to try at this point…

    No, unfortunately, that did not work.

    I can run Duplicator in my sleep, so it’s odd that something along the way has changed.

    In the morning I will run the test again on another server…see what happens. Thanks!

    I am actually already using the developer version–that was one of the first things I tried.

    Apache and PHP seem to be ok on my localhost server–I have other wordpress sites running. It must be something with this mediatemple site. Is this something I could submit a support ticket in order to get a closer look?

    Thanks for your help.

    Plugin Author Cory Lamle


    If you want to submit a ticket I can look into it…



    Unfortunately I’m having the same problem as above. I’ve tried commenting out the lines you said but nothing.

    Have you had any luck finding a solution?



    I ran a few tests to see where the hiccups are.

    I packaged a site on MAMP and set it up at Bluehost. Duplicator installed the site perfectly.

    Tested a site from Bluehost/server to MAMP and the installation failed. When navigating to installer.php, the file downloaded instead of running the installation.

    The installation php file download problem is from server to MAMP (for me), which never used to be a problem. So I have no idea what has changed.


    I may have found the reason to the problem on the support page of a different but similar plugin.

    In the .htaccess file my host (Bluehost) has added the following lines:

    # Use PHP5.4 Single php.ini as default
    AddHandler application/x-httpd-php54s .php

    If they are commented out before running the duplicator package the installer.php stops automatically downloading and works as expected.

    Plugin Author Cory Lamle


    Hey John,

    You might want to submit a support ticket or a new forum thread with your issue.. As this thread is get long and going in several different directions…

    @ndw81 Thanks for posting your particular solution back to the forum


    I’m quite sure it’s a .htaccess issue. I had the same issue; deleting .htaccess solved it – until installer.php extracted the archive, which wrote another .htaccess that gives the same problem. Now I’ll have to find what part of the .htaccess causes the issue and remove it from the archive…

    Plugin Author Cory Lamle


    Just an FYI… This info is documented here:

    -> Browse To:
    -> Find Section: “2. Installer => I get errors, plain/text, or a download prompt when browsing to the installer?”


Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘installer.php downloads instead of running the installation’ is closed to new replies.