Support » Plugin: Duplicator - WordPress Migration Plugin » installer.php creates HTTP Error 500

  • Resolved dollhousedigital

    (@dollhousedigital)


    Heya guys…

    Suddenly having probs with Duplicator.
    When I upload the zip and installer.php and then access the installer:
    mydomain.com/installer.php I get a 500 error.

    “This page isn’t working
    mydomain.com is currently unable to handle this request.
    HTTP ERROR 500″

    The error log states:
    [08-Jan-2018 22:44:45 UTC] PHP Warning: Unexpected character in input: ” (ASCII=27) state=0 in /home/mydomain.com/installer.php on line 161
    [08-Jan-2018 22:44:45 UTC] PHP Parse error: syntax error, unexpected ‘YŒöCq’ (T_STRING) in /home/mydomain.com/installer.php on line 161

    This same problem has happened on many different sites, with many different backups on many different new domains. I have tested it thoroughly multiple times.

    And the installer.php error is never on the same line number – this changes on every build.

    (I’ve added mydomain.com in by the way! Don’t wanna put my domain names here!).

    I am a customer of the Pro version however and this is working fine. So it’s no big issue but is a pain when I’m just throwing dev builds around that don’t need all the power of Pro.

    Hope you guys can look into this.

    Cheers…

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @dollhousedigital,

    Thanks for the feedback! There are a few items in the FAQ that may provide a solution to this issue, this one may get you going.

        – Why does the installer show as plain/binary text, a download prompt, or just not work?
        – https://snapcreek.com/duplicator/docs/faqs-tech/#faq-installer-010-q

    Notably, the option to FTP in binary mode can affect the installer, but it can also be related to some of the other issues mentioned.

    Let me know if any of them help~

    Heya,

    It appears the installer.php file is not working at all on the free version for some reason.

    I just tried another install and all I get is:
    Warning: Unexpected character in input: ” (ASCII=2) state=0 in /home/xxxxxx/public_html/mysite.com/installer.php on line 86

    Parse error: in /home/xxxxxx/public_html/mysite.com/installer.php on line 86

    (I added the xxxxx and mysite.com)

    If I use Duplicator Pro it’s fine however.

    My process is:-
    Create backup and download directly from duplicator to my local.
    Upload zip and installer.php via FTP (FileZilla).
    Go to the installer.php URL and install.

    This process has worked fine for a long time but now no longer works at all on the free version. This issue also occurs on many diff hosts. Very strange.

    I’m looking into it further but if you have any ideas please do let me know.
    Using Chrome & FileZilla.

    Cheers.

    Plugin Author Cory Lamle

    (@corylamleorg)

    Most likely it has something to do with how the file is being transferred. We have seen that issue before and 99% of the time it has to do with the FTP client and its mode. Did you try Option 1 and 2 under Parse Errors in the FAQ link above? Maybe try to transfer the file with cPanel?

    Hi Cory,
    Same problem here:

    Warning: Unexpected character in input: ” (ASCII=2) state=0 in /pages/b1/f8/d0010313/home/htdocs/powgrosshaendler/installer.php on line 163

    Parse error: in /pages/b1/f8/d0010313/home/htdocs/powgrosshaendler/installer.php on line 163

    transfer with cPanel also not working.

    Think i am going back to “WP-Clone” plugin.

    cheers

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘installer.php creates HTTP Error 500’ is closed to new replies.