Support » Plugin: Duplicator - WordPress Migration Plugin » Installer fails before step 1

  • Resolved imboeschi

    (@imboeschi)


    I’ve been trying to use Duplicator to migrate a website (to a host without WordPress installed, for production). I’ve done this successfully a few times in the past but recently made updates to the site for the first time in a year or so (it’s a small site for a friend so it doesn’t change much), and with the latest version of WordPress (5.1) and Duplicator Lite (1.3.8) for the WordPress source site, the following error message appears in the browser window when I visit the installer.php file:

    An invalid request was made to ‘step1’. In order to protect this request from unauthorized access please restart this install process.

    Restarting the process (by clicking on the hyperlink on the final part of the text) results in the same error message.

    I looked into the log files, but they don’t help much. The installer log file contains the final line:

    Mar 10 06:49:58 No detected errors so redirecting to the main installer. Main Installer URI = http://localhost/dup-installer/main.installer.php

    Inside the dup-installer directory there’s another log file but it has zero content.

    The installation server is running Debian 9.8, Apache/2.4.25 (Debian), PHP 5.6.36-0+deb8u1 (cli)

    The old version of the website I made with Duplicator/Wordpress (unfortunately I don’t know version numbers from the time the archive was created) installs and runs just fine.

    I did look through the FAQs etc and did a web search but couldn’t find anyone having quite the same problem.

    Any help much appreciated.

Viewing 15 replies - 1 through 15 (of 15 total)
  • I have the exact same problem, so I will follow this one 🙂

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @imboeschi

    If you want to submit a support ticket for this issue we can have a closer look at your setup. Please provide a link to this thread when submitting the ticket.

    Thanks~

    Hi Cory,

    Thanks, request submitted. Sorry for the late reply, I missed the notification that you’d responded.

    Just making a note here because benthek is also interested so trying to keep him/her up to speed.

    Chris

    • This reply was modified 1 month, 1 week ago by  imboeschi.
    Plugin Author Cory Lamle

    (@corylamleorg)

    Thanks for the update!

    Just to add, I’m also getting this on my remote server. Unfortunately I don’t have time to debug as against a deadline, just wanted to raise that others are experiencing this issue too! Hope it gets fixed soon.

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @everyone,

    If someone can give the developer version a try it may have the updates for your issue. The very latest version (1.3.9) can be found by following these instructions:

    https://downloads.wordpress.org/plugin/duplicator.zip
    – Uninstall your current version and install this one.

    Let me know if this solves your issue~

    Thanks~

    imboeschi

    (@imboeschi)

    I tried the 1.3.10 version (which from the release notes appears to address the problem) but that resulted in exactly the same error message.

    Should I try with the developer 1.3.9 version you posted above?

    Thanks for your help, I really do appreciate it.

    Best regards

    Chris

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @imboeschi

    Go ahead and submit a support ticket for this issue we can have a closer look at your setup. Please provide a link to this thread when submitting the ticket.

    Thanks~

    imboeschi

    (@imboeschi)

    Hi Cory,

    Thanks for the reply.

    I just submitted a ticket, although I’ve done one before and never heard anything about it, however perhaps I made an error on the first occasion.

    The ticket number is Y4U-SVS-DVWY.

    Best regards

    Chris

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @imboeschi

    Thanks for the update! It looks like one of our developers has replied to that ticket and is awaiting your response.

    Cheers~

    mugiwara20

    (@mugiwara20)

    I’m also having this error..

    imboeschi

    (@imboeschi)

    Hey @corylamleorg

    Thanks for the tip, I didn’t get a notification so I wasn’t aware there had been a response.

    Your developer is offering to help, but I need to set things up on my end before they can, and I won’t get a chance to do that until the weekend (I do this stuff for friends and family and my real job gets in the way sometimes).

    Anyway, thanks again for the heads-up and I’ll get to it as soon as I can.

    Chris

    Plugin Author Cory Lamle

    (@corylamleorg)

    No Problem… Thanks for the update!

    Hi Cory,

    Just wanted to let you know I’m not comfortable providing the access information to the website/server that your developer needs to determine what the problem is.

    No big deal, I’ll just let this one pass.

    Thanks anyway and best wishes.

    Chris

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @imboeschi,

    No Problem… Thanks for the update!

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.