[resolved] Installed/unpacked themes don't appear. (7 posts)

  1. stenberg
    Posted 5 years ago #


    I am using WP 2.8.4, and I am trying to change theme from the 'default' to a new one (Vigilance). The problem is just that whenever I have chosen theme and clicked 'install theme', all I get is:

    Installing theme: Vigilance 1.34
    Downloading install package from http://wordpress.org/extend/themes/download/vigilance.1.34.zip.

    Unpacking the package.

    And after that, nothing happens, and the theme doesn't appear in my 'themes' section, all I got there is 'default' and 'classic'. I tried with other themes too, but none works.

    Does anyone know how to solve this issue?

    Thanks on beforehand,

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    Can you access your site via FTP? If so, try downloading a new theme archive to your own computer, unpacking it and then uploading the entire theme folder to wp-content/themes via FTP.

  3. krembo99
    Posted 5 years ago #

    also check if it is not simply inside nested folders ..

  4. stenberg
    Posted 5 years ago #

    Downloading, unpacking and then uploading via FTP did the trick. Thanks. :)

  5. quint2black
    Posted 5 years ago #

    This answer has been most helpful as I have just experienced the same problem. And it works. Thank you.

  6. The Sandeep Goyal
    Posted 5 years ago #

    Downloading, unpacking and then uploading via FTP did the trick.

    But there MUST be some solution from wp-admin. I am wordpress expert, i know ftp and all.

    What for my clients? They want simply through wp-admin..

  7. dimartensson
    Posted 5 years ago #

    It sounds like your themes folder was lacking the necessary privileges. Try setting the wp-content/themes folder to read-write by owner and setting the webserver as owner.

    On a linux server:
    # chmod 774 themes
    # chown apache:apache themes

    If you're using a hosting provider they might have a way to edit permissions through their web interface.

    (You could set the infamous chmod 777 if you can't change owner, but then you'd have to revert that immediately since that makes the folder writable to anyone!)

Topic Closed

This topic has been closed to new replies.

About this Topic