WordPress.org

Forums

[resolved] Installed WordPress Theme But Header and Images Not Showing (11 posts)

  1. VegasTest
    Member
    Posted 6 years ago #

    Hello, I just uploaded the GreenPlayaz theme to my domain at http://vegastest.com but none of the images are showing up. There is no header or background images. This is what the theme is supposed to look like http://www.unodesignstudio.com/Demo/ so I am wondering what I did wrong. I uploaded the theme to my WordPress themes folder and activated it but I am not getting a header or background images. Did I do something wrong?

  2. moshu
    Member
    Posted 6 years ago #

    What is not uploaded - cannot be shown:
    http://vegastest.com/wp-content/themes/GreenPlayaz/images/bg-head.jpg/

    Make sure you uploaded the /images/ folder and ALL its content to the proper location!

  3. VegasTest
    Member
    Posted 6 years ago #

    Ok I must be an idiot :) , I thought you just uploaded the entire folder with the theme and images in it to the WordPress themes section via FTP and it automatically came up when you activated the theme. The images folder is in the theme folder. Am I supposed to upload it somewhere else?

  4. moshu
    Member
    Posted 6 years ago #

    It should work like that - you upload the theme folder and everything goes up.
    For some reason it didn't. Actually, can you see the image files in the images folder (via FTP)?
    Check the permissions? Upload again, only the images?

    Could you explain to me WHY when I try to see the default theme's images, the URL gets redirected here:

    http://vegastest.meteorfreaks.com/wp-content/themes/default/images/header-img.php

    Are you trying to use some redirect tricks in your WP? Messing with the 2 URL values in settings? Or what?

  5. VegasTest
    Member
    Posted 6 years ago #

    I am using Host Gator and when you set up hosting you do it under one domain, which was the meteorfreaks domain. When I add another domain it makes it a subdomain of the original domain you signed up with. Is that the problem?

  6. moshu
    Member
    Posted 6 years ago #

    OK, then maybe not.

    Were the images uploaded as binary files? Did you check the permission on the images folder and/or on the image files?

  7. VegasTest
    Member
    Posted 6 years ago #

    Wow, it turns out this was on my host's end and had to do with hotlink protection breaking the theme.

  8. moshu
    Member
    Posted 6 years ago #

    Ah, I always forget to check that because I have never had that activated.
    Good that you figured it out.

  9. boogersaregreen
    Member
    Posted 6 years ago #

    I am so greatful that you posted this Moshu. Because I use HostGator as well and my themes and images were not showing on the new wordpress 2.7 I am launching for a website. At first I thought it was an images permissions error and I was dreading have to change them because I have quite a few templates I am testing out.

    Then I saw your reply that it was a Hotlink problem, so I check hotlinks and it was disabled already.

    I ended up having to enable it, then disable it, last I added the direct link address to the hotlink list, enable it again and disabled it so that it stored the short form of the web address.

    That did the trick.

    So if you install WordPress 2.7 using Cpanel on HostGator.com, you'll need to go into your Cpanel, add the domain web address to the hot link protection list, enable it, and then disable it again if you want your hotlinks disabled, in order to get the themes thumbnails, and images to display on the front page.

  10. MeCanX
    Member
    Posted 6 years ago #

    Booger And Vegas! Thank You!!!! You just saved me a call to HostGator as I was searching all over Google for your answer and how to fix it and this post has saved me huge amounts of time!

    God, I seriously was like what is going on here? Why won't the template show up right!

    Thanks again as this solve my issue and I can sleep at nights now...LOL

  11. nadinecamille
    Member
    Posted 6 years ago #

    Thank you to all of you! Haha, and just to say how thankful I am, I signed up for an account here to comment. It was with the hotlinking why it was not appearing after all! Thanks again.

Topic Closed

This topic has been closed to new replies.

About this Topic