Support » Theme: Tracks » installed tracks theme – pagination on frontpage not working

  • Resolved mo2this

    (@mo2this)



    pagination on frontpage to further posts leads to erroe 404.
    Can anyone give me a hint what to do?

    Looking forward to hear from you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Greetings

    You could try Dashboard > settings > Permalinks … and click save.

    Good luck

    Hi,

    thanks for the answer .. I had tried that already. But just to be sure I tried it again and reset it from my custonm structure to the preset of year/month/postname … but no change.

    If I click on ‘next’ or ‘2’ on the frontpage bottom I get 404 error Url is
    …/page/2

    Any idea?

    Theme Author Ben Sibley

    (@bensibley)

    I have a few other things you can try.

    First, try switching themes. Does the pagination produce 404s with other themes?

    The next thing to try would be deactivating all plugins on the site temporarily. You can bulk deactivate them from the Plugins menu to see if this fixes the issue. If it does, you just need to reactivate them until you find which plugin is causing the issue.

    If this doesn’t work, could you share a link to your site?

    Hi, thanks for the thoughts.
    I tried it with the deactivation of all plugins already – no change.

    But I realized an other thing and recall that from installing themes earlier. Al works fine if I set permalinks to default. Problem is only I would like to have a little bit neater links as just ?234 to my blogposts.

    Also under the old theme I had to modify my permalink structure to …/index.php/year/postname .. for example. I tried that again. And generally have it working – sort of .. just that at the pagination at the end of the frontpage (I show 14 posts at the moment) the next then would also need to have the index.php/ inserted. I tried it manually and it worked. And so would the archives link.
    Here is my blog link: http://www.mindgap.org (currently set to the index.php version – half working.)

    In the old template it worked but with the so called PATHINFO (index.php insert) … here I still need to figure out how to add this to the pagination and the archives. The old template was not responsive that is why I would like to change.

    So far thank you for all the ideas!

    I deleted the old .htaccess file, saved the permalink settings to a standard version – this fixed the problem, as wordpress then creates a new one. Also I had set my htaccess file before temporarily to 666 .. obviously it was not rewriteable before …

    Theme Author Ben Sibley

    (@bensibley)

    Nice work! Glad it’s fixed now 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘installed tracks theme – pagination on frontpage not working’ is closed to new replies.