Support » Fixing WordPress » Installed today, Suffusion theme, but Posts: “The webpage cannot be found”

  • I’ve worked with Suffusion before and love it. So started a new project today, but for some reason something is royally messed up. First noticed that I couldn’t upload pictures. Then noticed that while my home page looks fine – the posts aren’t posting anywhere else. Click on a post on home page, and instead of going to a page with that post alone – you get a notice that the webpage can’t be found. And yet – when you published, everything seemed fine.
    Does this make sense? It’s publishing to the home page just fine – but no where else. No additional pages. I haven’t done anything to mess with perma links. I have reinstalled three times trying to figure it out. It’s 4 am. I need help.
    http://christsinternet.com/Blog/

Viewing 5 replies - 1 through 5 (of 5 total)
  • This does seem to be a problem with your permalinks. For starters try switching to another theme and see if your problem persists. Another thing to investigate would be any caching plugins that you might have.

    Moderator keesiemeijer

    (@keesiemeijer)

    moderator

    Do what sayontan says and set the permalinks to the default permalinks setting. And see if it still persists.

    Okay – changing the perma links seems to have helped the posts,

    But now…maybe uploading pictures was a separate problem? I tried a picture again, and got this…

    “Unable to create directory /home/wayne44/public_html/Blog/wp-content/uploads/2010/07. Is its parent directory writable by the server?”

    …Yet…this was the configuration created by WP.

    My thought yesterday was that I had messed up when I created the log in user name. I didn’t want wayne44, which is the log in for my server. So I put a different user name for the WP. Could this have messed everything up? Anyway, that’s what I’ve been trying to change when I’ve gone back to reinstall 3 times. But…Aargh…After reinstalling wp, I can’t seem to get Suffusion to reinstall normally. It gets hung up, saying that it can’t creat the directory. Public.html. It won’t install the normal way. So I’ve taken what was on my local and essentially ftp’d it into WP. I’m not sure if it’s then that the other login comes back, or when I reload the database. (the work I’d initially done prior to discovering the posting problem) I’ve looked through the database and it seems to use the wayne44 user name. Is the old Suffusion bringing back the other? Or is the user name not the problem at all? I’ve been in a circle, reloading everything three times already, only to find myself back at square one, with the pictures not loading.

    I fixed it! Thanks! I found some posts that said to change permission for wp/content/uploads to 777. It worked – yeah!

    thnx

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Installed today, Suffusion theme, but Posts: “The webpage cannot be found”’ is closed to new replies.