Support » Plugin: Rename wp-login.php » Installed then gave me "Error establishing a database connection"

  • Resolved kid_khaos



    So I recently downloaded and used this plugin as I was recommended by a friend.. Thing is as soon as I installed it, I was able to change the prefix from /wp-admin/ to /login-page/ just to try it.

    A few minutes later, I got the message
    “This either means that the username and password information in your wp-config.php file is incorrect or we can’t contact the database server at (my server details). This could mean your host’s database server is down.

    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?

    If you’re unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.”

    This has never happened to me before, and I’ve been using WordPress for some time. I figured it has something to do with MySQL database, but every time I log into my hosting (GoDaddy)and try to access MySQL it would just freeze and never load. I called Godaddy earlier today, and they told me it has to be some kind of error code on behalf of the wordpress program.

    I am able to access my website’s new login page, but as soon as I click login, it would say Database error.

    I was using numeric pretty link, along with the following:
    W3 Cache
    AdSense Explosion
    Simple Local Avatars
    Ultimate Page coming soon
    Contact us form
    and of course Rename Wp-login

    I had no problems with my database as this site was running fine.

    My best guess is that by changing the Wp-login to login-page, somewhere among the wp-config, there is a string of code or in MySQL that I would have to change?

Viewing 7 replies - 1 through 7 (of 7 total)
  • **Update**

    After switching between browsers in trying to open MySQL, I deleted the Plugin using FTP.

    Cleared all history (Cookies and Cache), and finally was able to access MySQL. Before opening it however, it gave me an error connection lost at MySQL database? The message disappeared within seconds so I couldn’t identify it :/

    I didn’t touch my database and went to check on my website. Since I deleted the plugin using FTP, everything is back on track. I can now access both MySQL and my website.

    I have a question now.. if I wanted to install the plugin again, would I get the same process?

    Plugin Author Ella Van Dorpe


    I don’t think this problem is related to the plugin. This plugins doesn’t touch the wp-config.php file or the database at all. In total there are two options saved in the database, just like any other plugin does it.

    You say you were able to “prefix from /wp-admin/ to /login-page/”. DO you mean wp-login.php? This plugin doesn’t rename wp-admin. You didn’t change any file or folder names right?

    “every time I log into my hosting (GoDaddy)and try to access MySQL it would just freeze and never load.” Was this before you installed my plugin too?

    I would try to install this plugin again. But just install and activate it, don’t change any options or permalinks and don’t do anything else. Can you give me the url of your website after that?

    Yes, I meant wp-login.php. Sorry I’m a bit tired it’s passed midnight here.

    No I didn’t change anything in the databases, nor was using any other plugin that would cause such event?

    I was able to do everything a normal wordpress website would run, before the plugin just fine. I installed the plugin by uploading through wordpress, then clicked activate.
    It gave me the option to rename wp-login.php and I did too login-page.

    I’ll try to activate it right now..

    Thanks for your reply btw 🙂 means a lot I’m not alone here!

    Let me take disable the coming soon plugin..

    I just activated it and changed it so my new login page is..

    Seems to be working just fine 😮

    Plugin Author Ella Van Dorpe


    Ah it works 🙂

    Like I said, I don’t think it’s related to this plugin, it must have been coincidence.

    Btw, if you have W3 Total Cache enabled, read the information a bit further down here:, and add the word you rename wp-login.php with (like “login”), to the list of pages not to cache (if you have page cache enabled.

    Done and Done ! 🙂

    I hope I added that login page in the right place haha

    I still have work to do on the site, but this plugin took some work off my shoulders!

    Great plugin 5/5

    Fantastic support! I can’t thank you ever so much!!

    Plugin Author Ella Van Dorpe


    Thanks! I’ll mark this as resolved. 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Installed then gave me "Error establishing a database connection"’ is closed to new replies.