WordPress.org

Support

Support » Multisite » [Resolved] Installed SharDB, can't visit newly-created blogs

[Resolved] Installed SharDB, can't visit newly-created blogs

  • davegregg

    @davegregg

    I have migrated my large multisite WordPress network to MediaTemple DV (VPS), and installed SharDB (with 256 DBs, a home DB, and a global DB). All the pre-existing blogs appear to be working just fine. I can visit them and change them. (For example, a working blog on my network is here: http://test1.authorsxpress.com/)

    But while I appear to be able to create new blogs error-free, I can neither visit them or their dashboards. For example, I’ve created the following blog: http://postmigration1.authorsxpress.com/
    When I navigate there in my browser, or to the corresponding dashboard (which of course also uses the subdomain), I am redirected here: http://authorsxpress.com/wp-signup.php?new=postmigration1
    …with the error “The site you were looking for, http://postmigration1.authorsxpress.com/, does not exist” as I’m sure you can see.

    Here’s my current .htaccess:
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule . index.php [L]
    # END WordPress

Viewing 15 replies - 1 through 15 (of 15 total)
  • Moderator Andrea Rennick

    @andrea_r

    Look and see if the tables were created in the right db. Could be in the move the db users don’t have the right permissions on the new server to make tables. or the collation got changed, which will give the same error.

    davegregg

    @davegregg

    Alright, yesterday I created a new blog, as you know. I also deleted two old test blogs, which you didn’t know. Today I logged back in and the two deleted blogs are back and the one I created yesterday is gone completely from the dashboard.

    I also noticed that I no longer have the DB column in the site list. But ‘shardb-admin.php’ is still in the mu-plugins folder and I am logged in as the network admin.

    ‘db.php’ isn’t showing under the Drop-ins plugin section, though it’s been correctly placed in the wp-content folder.

    Also, when I navigate to the site list, it loads slowly enough that I can watch the individual sites populate one by one.

    I’m looking into the where I am the DB user.

    davegregg

    @davegregg

    My DB list looks like this by the way:

    prefix_00

    prefix_ff
    prefix_global
    prefix_home
    prefix_wrd1 [the original database]
    horde
    mysql
    phpmyadmin_[randomchars]
    psa
    sitebuilder5

    Moderator Andrea Rennick

    @andrea_r

    Today I logged back in and the two deleted blogs are back

    either multisite or shardb puts back deleted blogs. Someone restored some dbs somewhere. Given there were other changes, it looks like something got moved somewhere somehow.

    davegregg

    @davegregg

    This is my current wp-config.php file. Should the original WP DB be defined as DB_NAME?

    define(‘DB_NAME’, ‘prefix_wrd1’);
    define(‘DB_USER’, ‘[user]’);
    define(‘DB_PASSWORD’, ‘[password]’);
    define(‘DB_HOST’, ‘localhost’);
    define(‘DB_CHARSET’, ‘utf8’);
    define(‘DB_COLLATE’, ”);
    require(‘db-settings.php’);

    Also note that my original WordPress database has the same prefix as the new ones. Could that trip up the SharDB code?

    My PHP error log may have discovered the initial cause: a plugin (Diamond MultiSite Widgets) was caching stuff. I’ve disabled that now. No change. I stepped back through the instructions, removing SharDB’s files and the addition to wp-config.php, and then redid them. But nothing I do causes “db.php” to appear in the Drop-ins list, the DB column appear in the Site List, or the SharDB Migration option appear in the Tools menu. How do I get SharDB working again? Would performing the table migration again work? If so, how can I get that option back? I’m at a loss, and unfortunately I’m a SQL & PHP novice.

    davegregg

    @davegregg

    That original DB, by the way, still has the 2,880 tables if that matters.

    Moderator Andrea Rennick

    @andrea_r

    Do you have the install instructions?

    davegregg

    @davegregg

    Yes. I bought your ebook.

    davegregg

    @davegregg

    Would it perhaps be easier to fix this if I start over from scratch from my backup of the original database?

    db.php would not just disappear from your install. Someone or something removed it or restored your account.

    Are you running a backup plugin/service of some kind?

    On the original problem- if your sites worked before you migrated you don’t need any changes to your rewrite rules, .haccess or vhost config.

    The fact that you don’t get error messages when you create a site does not mean that there were no errors. If you charset & collation are mismatched between WP and your DBs then site creation will appear successful.

    If you have to manually create subdomain accounts in your MT dv, then their might be an issue there.

    davegregg

    @davegregg

    db.php isn’t exactly disappearing. It’s in the proper folder in the filesystem and I’ve double checked its contents. Something is preventing it from appearing on the Drop-ins menu. I think I’m going to delete all the databases and files and start from scratch from my backups.

    davegregg

    @davegregg

    Alright, I worked it out. The problem was that sometime over the course of the night the domain name switched from the Mediatemple nameservers BACK to the Bluehost nameservers, and so what I was seeing when I was logging into the WordPress installation wasn’t the new multi-db VPS installation, but the single-db installation still sitting on the Bluehost server — thus the reason it appeared that something set my WP installation back a day. I got it fixed and now everything appears to be working perfectly, SharDB and all.

    Thanks guys! I’m glad it was something simple. 😀 Thanks for the great plugin and the instruction manual!

    Moderator Andrea Rennick

    @andrea_r

    Oh *whew* cuz that was creepy and I was too tired to think of checking DNS records. 😀

    Andrea had the same DNS flip back to the old site about 3 years ago. We scratched our heads quite a bit before we figured out what was up. Now what I do after making my backup but before flipping DNS is post something (or leave it on draft) so I can look and see which site I’m looking at.

    davegregg

    @davegregg

    Yeah that’s what I ended up doing to test it, basically. I just dropped a different comment in each footer.php and viewed the source of the front page. That was zany. Well thank you guys for the help! Now to test some plugins and we’ll be back to business! THANKS!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Installed SharDB, can't visit newly-created blogs’ is closed to new replies.