Support » Plugin: Really Simple SSL » Installed Really Simple SSL twice and got 404s.

  • Twice I installed Really Simple SSL and thereafter was not able to do anything with my WordPress site because 404 pages came up. It took a long time to have my host finally fix the problem. I won’t try it again.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Uninstalling is just 3 steps, so why would it take a long time?

    If you had contacted me I could have helped you out. In over 3000 installs i never encountered 404 pages. But as you didn’t contact me, we won’t find out what caused it. My guess is a plug-in conflict.

    It took a long time because all I came up with were 404 pages. I could not simply uninstall it. I had to deal with the 404 pages. Finally my host fixed it but then when I tried the plugin again it happened again and I had to have my host fix it again. The main page appeared okay after that but the links all got 404 pages, so again I had to have my host fix it. The problem was in htaccess. Since then I got SSL a different way and will not recommend that plugin to anyone.

    Could you say which web host you use so others know to avoid them? This plugin should work with the 95% of web hosts who have their .htaccess and/or permissions set properly.

    This gave me 404 error and took my server completely of the web.

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi,
    I can’t reproduce this error, so it has to be either a plugin conflict or a server configuration.

    did you try to remove the .htaccess rules? As described here:
    https://really-simple-ssl.com/knowledge-base/my-website-is-in-a-redirect-loop/

    Other things which might help:
    Saving the permalinks again
    Flushing site cache

    I can’t really help without more details, and without feedback on the things that work or don’t work for this issue.

    To research this issue I’d need the result of the ssl-test-page, and if possible the debug log ( with error logging on this is also possible when site is not accessible).

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Installed Really Simple SSL twice and got 404s.’ is closed to new replies.