Support » Plugin: podPress » Installed Podpress – Generates error line in System Information section

  • Resolved Richard Scholtz

    (@richardscholtz)


    Hello

    I just installed Podpress. Loaded two media files and they play well. It assigned itself AUTOMATICALLY to some audio books and plays those two which is awesome with the media player that just popped up on those pages…… So far so good.

    On the General Settings page below Premium content there is a section called System information. It displayed these two lines of text!

    ———————————————————-
    Warning: Missing argument 2 for wpdb::prepare(), called in /home/ps85v6/public_html/wp-content/plugins/podpress/podpress_admin_general_class.php on line 833 and defined in /home/ps85v6/public_html/wp-includes/wp-db.php on line 990

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/ps85v6/public_html/wp-content/plugins/podpress/podpress_admin_general_class.php on line 834 and defined in /home/ps85v6/public_html/wp-includes/wp-db.php on line 990
    ——————————————————————
    What is that and how fatal is that and what will it affect later……like Itunes feed?

    the url of the website is http://www.servantofmessiah.org
    It is a small non profit…..

    The feed caching and the Stats are working fine……but where do I go to fix this.

    1) Can I edit the settings file in the plugin

    2)or is this a file on the server in the public html file and that needs editing.

    3) What is a missing argument 2?

    Will this affect my Itunes….which will be submitting this month

    Please help…..this is above my skills

    Regards
    Richard Scholtz

    http://wordpress.org/extend/plugins/podpress/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author ntm

    (@ntm)

    Richard thanks for reporting the issue.
    This issue is related to some changes in WP 3.5 and how podPress uses the wpdb:prepare() function. But the message you get is only a warning message no bad error. You may hide it for now as explained here: http://make.wordpress.org/core/2012/12/12/php-warning-missing-argument-2-for-wpdb-prepare/ or do nothing.
    It is possible that you see such a message at different places on the admin pages of your blog (like on the dashboard: http://wordpress.org/support/topic/podpress-incompatible-with-wordpress-35). But this function prepares data input before it is stored in the db. It has nothing to do with the output of the plugin, especially not the feed output (no such message in the feed).
    So you do not need to fix anything.

    I work on an update for podPress. The current Development Version includes already a bug fix for this issue.
    If you want to try this version then please make a backup before you start.

    I hope that I can release the update in the first or second week of January.

    Regards,
    Tim

    Hello Tim

    Thank you for such a complete and quick reply. If you are writing an update…do not forget to increase the size and notations on ITUNEs new Image specs……I think they want 1400×1400 pictures now otherwise not in the Itunes directory.

    I want to contribute to the paypal donations on Dec 27th ….because this a great program but the only paypal is for these 3 guys who were authors

    podPress Donors

    Will that $$$ get to you ….as you are doing all the work??

    If you have a web page –then update WordPress

    Anyhow thank you ….

    Regards

    Richard
    [ Signature moderated and support is offered via the forums and not email. ]

    Hello Tim

    Loaded the Beta Plugin//Developmental version —worked just fine and the error messages are all gone. You were right!!!

    Thank you.
    Richard

    Plugin Author ntm

    (@ntm)

    Will that $$$ get to you ….as you are doing all the work??

    No, the Donation button is only for Dan, the original author of the plugin.

    I think they want 1400×1400 pictures now otherwise not in the Itunes directory.

    You are right. It is will be adjusted.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Installed Podpress – Generates error line in System Information section’ is closed to new replies.