Support » Plugin: Simply Schedule Appointments – Booking Calendar » Installed plugin, but not seeing anything.

  • Resolved garymgordon


    I installed the plugin, set it up and all seemed to be going well. But I went to the page where I added the shortcode, but I didn’t see anything. I’m presuming there’s a conflict with something, but I wanted to ask before I have to start deactivating all my plugins, etc. to figure it out. Any thoughts? – Gary

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Simply Schedule Appointments Support


    Hello @garymgordon

    This does seem like a plugin or theme conflict. An easier alternative to deactivating your plugins individually would be to use the Plugin Detective plugin.

    Just navigate to the page you’re having trouble with and select Troubleshoot from the top-black WordPress bar. Open a new case in the plugin. And select Simply Schedule Appointments as a required plugin.

    It should narrow down any plugins that are causing conflicts, if that’s the case.

    Please feel free to send us a message to our address and send us a link to the page you’re having trouble with. We can continue to take a look through there too.

    Natalie G

    Thread Starter garymgordon


    Thank you VERY much. I found the issue was related to iThemes Security Pro plugin. The issue was due to this feature which I had enabled:

    Filter Long URL Strings
    Limits the number of characters that can be sent in the URL. Hackers often take advantage of long URLs to try to inject information into your database.

    I’m concerned to disable this based on their statement. Is there any way around this so I can leave it enabled? But currently, with it enabled, your plugin doesn’t work.

    Any thoughts? I just curious what you might suggest.


    Plugin Contributor Natalie MacLees


    Hi Gary,

    I’m glad you were able to sort out the issue and find the cause. We’ve had similar issues with that settings in iThemes security and we’re not alone – several other plugins have issues with this setting, which is a bit overly aggressive and unfortunately, not at all adjustable. It would be really helpful if iThemes offered a way to mark certain URLs as safe so that you could continue to use that setting but allow certain requests through. We’ve made that request to the iThemes team, and we’ve found threads where other plugin authors have requested the same, but so far we haven’t had much luck.

    There doesn’t seem to be anything we can do from our side to get around that setting, but we’ll keep asking the iThemes team for some flexibility there so we can get our plugin working with theirs. You can add your voice to the request to get some flexibility with that setting from the iThemes team – the more people ask, the more likely they are to implement it.

    Thread Starter garymgordon


    Thanks. That helped.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Installed plugin, but not seeing anything.’ is closed to new replies.