WordPress.org

Support

Support » Installation » [Resolved] Installed Great! — But Can’t Login to Admin

[Resolved] Installed Great! — But Can’t Login to Admin

  • Hello:

    1) Installation was easy, and can view the new blog:
    http://www.wiu.edu/library/wordpress/

    2) However, Admin login repeatedly fails — supplying correct username/password and clicking “login” simply returns me to the same login page (with user/pass blanks unfilled). The system’s authentication sequence is working, since if I supply an incorrect user/password combo it generates an error message.

    3) I’ve cleared cache and cookies repeatedly; have enabled “cookies”; have tried to login via IE, Firefox, and Netscape. Have reviewed: http://codex.wordpress.org/Login_Trouble

    4) I’ve reinstalled repeatedly with same results.
    Here are the specs: http://www.wiu.edu/library/test/php_info.php

    Any last suggestions, before I purse another OS product?
    I was really hoping we could use WordPress!
    Many Thanks, Isaac

Viewing 15 replies - 1 through 15 (of 16 total)
  • When you reinstalled did you get a different password?

    Have you tried logging in from a different computer?

    Some other thoughts to add

    1) be sure you’re entering in the admin name and password (“admin” is the default) case-sensitively.

    2) When in doubt about the auto-generated password, force your own: http://www.tamba2.org.uk/wordpress/phpmyadmin/

    3) Anything going into your web server’s error logs when you try and login?

    Yes, each time that I’ve reinstalled a new password has been successfully generated. A few minutes ago (I’ve tried this twice), I manually generated a new password via phpMyAdmin (M5). The resulting password processes without an error message, but am still returned to the login page.

    I’ve tried several computers (and clearing cache/cookies with each), but to no avail. Am currently at a different location (different computer/IP), but continue to receive same response. I’m carefully inputting the user/password combo (also, this is confirmed by the fact that I do not receive a password error message unless I intentionally (for testing purposes), input a “wrong” password).
    I’m clearing cache/cookies between attempts and trying different browsers. Must be something else?

    Don’t have direct access to server logs, but will pursue.
    Thanks for your suggestions — anything else I might try?

    Maybe allow one of us to register to that site and see if we could login?

    Sure — what’s the best way to allow “one of us”?

    Have you tried removing the tables in your database? I’d go for a fresh install, I’d even download WP again just to elevate any possible corruption.

    I don’t see a way to register on your blog. After looking around, I don’t see it on other blogs either. Was it removed from the default template in newer versions of WP?

    Glo – No. He’s running default. So in the sidebar, look for “Meta”. First option below that is “Login”.

    I see the login but don’t see “Register”. You can’t have a username and password without registering, right?

    Yes, I’ve totally dropped the database with each re-install.
    Have also downloaded fresh WP software and reinstalled three times. Any other ideas?

    Okay, by typing in wp-register.php, I got a message stating that user registration is currently not allowed.

    isaach, try logging in again, then place wp-admin.php at the end of the url – http://www.wiu.edu/library/wordpress/wp-admin.php

    And see if you get inside the admin area.

    Hello…Yes, I see the same “registration not allowed” message when I visit here: http://www.wiu.edu/library/wordpress/wp-register.php
    I assume if I could login to Admin, I could enable this?

    Glo, not sure I understand your last message about adding “wp-admin.php” (can’t find a file by that name). However, when I go to this URL: http://www.wiu.edu/library/wordpress/wp-admin/
    then I am automatically redirected to the following URL which displays a login screen. Is this to be expected?

    http://www.wiu.edu/library/wordpress/wp-login.php?redirect_to=%2Flibrary%2Fwordpress%2Fwp-admin%2Findex.php

    The above long string is also the resulting URL that is always returned after supplying my correct username/password (takes me back to the same place).

    Does anyone know if this “re-direction” sequence in the URL should be occurring? It’s like there’s a loop.
    Thanks for your help!

    Does anyone know if this “re-direction” sequence in the URL should be occurring?

    It is working as it should. If you’d like to send me the password you got, I can try loggin in – glo (at) wild-mind.net – just to be sure it’s not just you or your computer.

    Reinstalled again…issue continues.
    Any luck with the login info I sent, Glo?

    Had to dig hard, but we finally found a solution. We began looking at our server traffic and discovered that for some reason WP is sending a redirect from the login page to the “wp-admin” page (that makes sense), but then is ALSO sending a “GET” redirect back to the wp-login.php page. This second call is taking precedence, which is why we were in a never-ending loop and couldn’t login.

    The temporary solution, at least it is now working for us in a non-Apache environment (we run Sun ONE Web Server/6.1), was to make the following change to the “pluggable-functions.php” file located in the “wp-includes” directory. On line 269, we changed the code to:

    if (! $is_IIS) {

    Apparently, this configures us as a “non-IIS” server. With this single change, we can now login without incident. However, note that the 2nd call is still being made. If anyone knows where to forward this info, perhaps it should be reviewed by WP development folks — seems to be an issue… Thanks for everyone’s help. Now we can begin with WP! –isaac

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] Installed Great! — But Can’t Login to Admin’ is closed to new replies.