Support » Plugin: Memphis Documents Library » Installed and activated the plugin, but no menu items are showing up

  • Resolved ralnic

    (@ralnic)



    It’s a new install of wp. V4.9.8 on a Windows server 2012 R2. We’re trying to create a local intranet site, so there’s no public access. The plugin is V3.9.9. It seemed to install and activate ok, but I’m not seeing the Memphis Document menu when I’m logged in as administrator. What am I missing? Thanks.

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Author bhaldie

    (@bhaldie)

    please disable all other plugins and see if you can see the menu “Memphis Docs”

    • This reply was modified 4 weeks ago by  bhaldie.
    ralnic

    (@ralnic)

    Thanks for the quick response.
    Same thing. It was the only plugin installed other than the two default plugins, and they were not activated.

    Plugin Author bhaldie

    (@bhaldie)

    can you open a browser inspector and let me know if you see any errors.

    I’m new to this, so I’m not sure what I’m looking for. But when I toggle the Dev Tools in Firefox, I don’t see anything showing up as an error.

    When I am editing a page, or create a new one, I do see the ‘Add mDocs File’ or ‘Folder’ buttons at the top. But no ‘Memphis Docs’ menu item in the list at the left.

    Plugin Author bhaldie

    (@bhaldie)

    im not sure why you won’t see its a standard add like any other plugin. are you positive that you are a administrator that would be the only thing that I can think of.

    Hmm. I am having the same issue after updating today – no memphis documents menu item – no console errors either and update seemed to be successful.

    Will do some more checking.

    Plugin Author bhaldie

    (@bhaldie)

    try downloading the tool User Role Editor and seeing if the cap is active for Admin “mdocs_allow_upload”

    This is strange. No mdocs caps at all using User Role editor.

    I deleted v 3.9.10 and went to an earlier version 3.9.5. Still no menu item.

    Then reinstalled v 3.9.10 (have not accessed mdocs admin panel in a month or two. No menu item. Then checked my mdocs posts – all were gone! Went to a backup and recovered posts and do see files on the frontend.

    I have caching deactivated and tried deactivating all other plugins. Nothing has worked thus far.

    Next Steps?

    Plugin Author bhaldie

    (@bhaldie)

    that cap needs to be there without those caps mDocs will not work. What has changed on your server something or someone has removed those caps and you need to figure out what. My code never removes caps so it has to be somewhere else.

    OK – after extensive testing here. mdocs 3.8.5 is the last version that works on my site. I tried versions after and upto latest and it does appear to be a cap/permission issue.

    Testing has been done with only mdocs and user role editor activated. When I go to v 3.8.5.1 or higher I get the message “Sorry, you are not allowed to access this page.” when trying to access the mdocs admin panel (left that panel page open to see when things break). Works on 3.8.5, breaks at 3.8.5.1 and higher.

    Role editor indicates cap of mdocs dashboard for versions up to 3.8.5, nothing for mdocs above that version. Not sure when it changed to mdocs_allow_upload but I have not changed admin permissions using Role editor – and from what I can tell (all other plugins deactivated), something is affecting the cap/permission on version 3.8.5.1 and higher other than plugin conflicts.

    Would like t help get to the core issue here and have been testing on my staging site, if you want to take a look. I am leaving v 3.8.5 active there and will revert on my production site until we can find a root cause.

    Thank you

    Sorry, I’m not much help with troubleshooting this. As I said, I’m new to wordpress and web building, I’m not familiar with what ‘cap’ is or how to check it. Mine is a brand new install, but I did verify that I was logging in as an administrator.

    Plugin Author bhaldie

    (@bhaldie)

    download the plugin User Role Edit:

    https://en-ca.wordpress.org/plugins/user-role-editor/

    enable the setting to view administrators.

    Take a look and see if the cap “mdocs_allow_upload” is checked in the User Role Edit plugin.

    Thats the best I can do to explain how to get the information you need.

    Plugin Author bhaldie

    (@bhaldie)

    @dt123 very weird, Im going to take a closer look at my code for 3.8.5.1 and see what the issue might be.

    My first guess would be a patch I implemented. Hotfixes are always X.X.X.hotfix so ill start there.

    Me again. I am still trying to get the Memphis Dos menu Item and mdocs_allow_upload in user role editor. Not sure where how, when things went south but can’t seem to get any version working …, so pretty sure it is my system.

    Have tried everything I know to do – deactivating all other plugins, deleting mdoc and reinstalling, change theme to wp 2017. Could it be something in the database tables?

    Any help you can give me is much appreciated.

    Plugin Author bhaldie

    (@bhaldie)

    So just to be clear you can’t add the cap “mdocs_allow_upload” when using user role editor?

    Or you just don’t see that cap at all?

Viewing 15 replies - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.